Touchscreen / Google / Arrow Disappearing

I'm following up on this previous ticket. Wasn't sure if it would be better to start a new thread or not, but here is the previous one.

I can still make this happen with the latest WebView2Loader_x86.dll and FNCMaps 4.0 version.

Basically, when using Google Maps in the FNCMap control, if you use a touchscreen by pinch-and-zoom, the entire Delphi application seems to go into a tablet mode. Even if I move the mouse on the touchpad of the laptop, I cannot bring the cursor back. Our users are frustrated with this because they cannot see where the mouse cursor is.

If you use the touchpad for other applications, the mouse comes back, but as soon as you interact with our Delphi app, the mouse disappears again.

I've even tried doing this: Screen.Cursor :=crDefault;

If I don't use the map, the cursor is fine. The way it becomes an issue is if you use the touchscreen right on the Google map. This has happened on a variety of laptop brands.

Have any way of getting the FNCMap out of Tablet mode, which is what I think it is in?

Using Delphi 10.2 Tokyo.


We are not aware of such an issue in TMS FNC Maps.
Does the issue only happen with the TTMSFNCMaps component or also with a TTMSFNCBrowser component?

I don't know about the Browser since we don't use that component and I'm not sure even if I tried, it would be a fair comparison (even if it is the underlying engine).

Does anyone in your office have a touchscreen they can test it on?

We are currently investigating this issue and will report back as soon as possible.

It's been about a month and almost seven weeks since the last update on the 4.0 version. Is there a version coming out soon? I ask because we have a User's conference coming up, and I know this is affecting many of our users, and they will be asking us about it again.

After investigation this seems to be a general browser shortcoming in the Delphi framework. The issue can also be reproduced with the TEdgeBrowser. We are currently not aware of a workaround or a fix.
We have reached out to Embarcadero and are awaiting their response.

Have you heard back from Embarcadero on this issue?

Unfortunately we have no news to share on this issue for now.


So, you have not heard back from Embarcadero? You stated you put in a support ticket. Have they not responded in the last 30 days? I'm asking because if you didn't put in a ticket or they haven't followed up, I guess I will start a new case. I was waiting for the response to your ticket.

I would recommend opening a ticket with Embarcadero for further assistance on this issue.