TMS WEBCore VSC 1.9.85684 update broken

Win10/VSC 1.66.2


the update from yesterday is not working properly. The TMS Command panel is empty:

Calling the TMS Install packages give me this message:

I already tried complete TMS WEBCore deinstallation, and new installation 2 times.

I reverted to 1.9.85543 again.

Best regards

Did you have additional packages installed in the IDE?
If so, first remove these and then recompile & reinstall in the new version.

Investigating this one.

I new update is available on the marketplace, v1.9.85691, please, check it out. If you still have some issues, try to update your VSC version. Thanks!

I had the same problem.

Apparently an automatic update to TMS WEB Core v9.85691 was forced on my system tonight without my consent.

First symptoms:

  1. Main Form layout of the application destroyed
  2. Unlicensed version warning

Reactivated the license

  • TMS Command tab in VSC is missing all the commands
  • Trying to run the project fails with:
    tms command 'rad4.tms.web.port.debug' not found

Found this thread

  • removed the TMS Web Core Extension form VSC
  • disabled (not uninstalled) all other extensions in VSC
  • reinstalled TMS Web Core and reactivated license

The Commands are back and the project can be restarted.
Main Form layout is still destroyed.

  • Re-enabled all my other VSC extensions

Still working
Main Form layout still destroyed.

Really wish software vendors would stop to forcing updates on us whenever they feel like. We do actually also have work that needs to get done in time. Instead now I spend the rest of the day trying to get back to where I already was yesterday.

VSC Code
Version: 1.68.0-insider
Commit: ba2dd825803b5f95d5dcce927afc3a4882ed0f84
Date: 2022-05-19T05:16:16.887Z
Electron: 17.4.3
Chromium: 98.0.4758.141
Node.js: 16.13.0
OS: Linux x64 5.4.0-110-generic snap


I switched off the automatic extension updates, VSC just shows me that there are updates available.

Thank you Jose,

the v1.9.85691 seems to work again.

It is the Microsoft marketplace that has this auto update mechanism.
You can disable auto extension update:

Opt out of extension updates#

By default, VS Code will also auto-update extensions as new versions become available. If you do not want extensions to automatically update, you can clear the Extensions: Auto Update check box in the Settings editor (Ctrl+,).

If you use the JSON editor to modify your settings, add the following line:

    "extensions.autoUpdate": false

Visual Studio Code Frequently Asked Questions.

Do you have more details about what exactly is broken in your main form layout?

Thank You for the tip!

I have opened a new topic for my findings on the from layout problems, to avoid hijacking this one.


just saw the latest v1.9.85702 on the marketplace. Do you suggest to upgrade to this version? Any major fixes?

Best regards

It has 1 fix for control alClient alignment handling