Something broke with the last version combo

I didn't take note of version or exact errors, but everything on VSC was working great with the WebCore/FNC version combination upgrade I did on Feb.23 on both windows 11 and macOS Monterrey. (versions presents on my tms download area on that date).
Last week I saw that new versions were there for the FNC components and I reacted to my "update fever" and upgraded again.
This time everything installed well, but when pressing ctrl-12 to open the form designer, a lot of wierd errors were shown, basically telling that the fnc modules can not be loaded. Errors were on the I switched to the windows and found the exact same problem.
And when closing the error dialog on the IDE, a bunch of errors saying that webcore components like WebEdit or WebLabel were can't be found. This means that my forms can lose components so I closed everything and made a test application just to be safe, but it has all the same results.
Long story short, after some uninstall and install, activation and test cycles, nothing worked so I had to reset visual studio code to factory condition, and I installed the version backup I had FNC suite from Feb. 23, 2022, with the current online install version of WebCore from within VSC.
From the error presentation and being exactly the same on mac and windows I would say it is not local to my machines.And now it is working fine again.
Just wanted to report this.


Is this resolved now with the latest version or did you roll back to the previous version?

As far as I see, the current versions in my download area are the same that had the problem. I just reverted to the versions (I mean, WebCore and FNC Suite for VSC) that I downloaded and installed on Feb. 23.
Could be that just Webcore is fine, but when installing FNC Core and the other components I have the errors.
The correct debugging procedure would be installing one by one and test, but sadly at this time I prefer to use the proven working version because am in the middle of a project.

If you plan to upgrade and notice errors, please keep a log and then attach it here, so we can further investigate. Thanks for the feedback!

You are right. Normally I would do just that but is hard when being under pressure. Sadly I did the upgrade just before leaving to a demo with my customer and when I got there I noticed it wasn't working, basically I panicked, deleted everything and used my Feb 23 download backup. But am pretty sure it is the download (fnc and webcore) combination that is still on my download page:

v3.7.2.0 | Thursday, February 17, 2022

v1.8.0.0 | Thursday, February 17, 2022

v2.0.5.7 | Tuesday, January 25, 2022

TMS FNC Dashboard Pack
v1.2.6.0 | Tuesday, January 25, 2022

TMS FNC Cloud Pack
v1.4.2.0 | Thursday, February 17, 2022

v3.0.2.0 | Thursday, March 3, 2022

v1.9.75482 | Tuesday, February 22, 2022

As for FNC core, I tried to download it today to see the current online version but it just downloads an error text that says my login registration is invalid. And that is happening for any download. Maybe some system glitch.

I think I know what happened, because it happened again and I didn't install uninstall anything this time. I rebooted the mac in the morning for some updates. (mac air m1, monterrey 12.2.1) and used VSC with TMS all morning the windows 11 laptop. In the afternoon I switched to the mac,copied my VSC project to it and opened the project.
This time the first thing that happened is that webcore said it is an unlicensed version so I entered my email and code, and it reactivated. I just opened the project and when switching to the form designer I had the bunch of error messages again about not finding the FNC core and the QR, and XSLX components. So I checked on the install extensions options on the side bar, but all extensions are listed there. Exited and restarted VSC a number of times with the same result.
I figured out that I could try to just reopen the folders, and from the ide recompile and reinstall the components at this point, so I did that.
To my surprise, it worked just fine. So my theory is that the sudden lost of the licensing information could be the cause and it makes somehow disappear the FNC suite and other components.

I tried to download the most recent combination of packages again from my download page but it still is just downloading an error.txt file saying my registration is not valid. I tried, however, with the susbcription manager and it downloads all. Sadly I need to download the VSC versions and none of that downloads anything from the web page.Just the mentioned error text file.
Will try tomorrow, hopefully this is just a server problem on the web page.

I tested your account from here but could not see an issue downloading from your account.
Possibly, you are not using the latest credentials. We resent your latest credentials by email.

Thanks Bruno. It definitely is a credential related problem. I received the credentials, and I could download now with an older credential set. The newest one doesn't work. I replied over email indicating which one works. Thanks.

It should be fixed now.

Thanks, I just tested and it is working again normally.

It happened again (Errors when switching to the form designer).
TMS Web Core VSC was working last night just fine. One thing I had to do is to reboot windows 11 because of a Windows update that was insisting.
This morning I opened my project, and when switching to the Form Designer, a long error popped indicating that none of the components are found.
My first guess from experience is that WebCore updated itself within Visual Studio Code, so I try to run a new project. Indeed, a message pops telling that the application was generated with unlicensed software.
In conclusion, when this happens, I have to put my license information. But I also must reinstall all components. Seems that when WEBcore forgets that at some point it had the components installed.
It is not a complete dealbreaker, but having to enter my license and reinstalling all components take at least 15 minutes, IF I have my license information at hand, which I normally have on a secure backup disk I have not usually connected to the laptop.

Please make something to prevent this from happening, since it is quite too often, without any reason. This time I took a screenshot of some of the errors and have the versions am working with( Not taking into account the third party components)

WebCore vor VSC 1.9.85543
Fnc Core:
Fnc Ui pack:
Fnc Chart:
Fnc Blox:
Fnc Dashboard:
Fnc Cloud:
Fnc Maps:

When we release a new version, sadly, the installed component packages need to be recompiled. This is a limitation of how the pas2js compiler works and a kind of similar to needing to recompile packages / DCU files in Delphi when a new version is released.
So, just reopen & recompile these packages and you should be fine again.

Also you can opt out of automatic extension updates, so you will update manually:

Now I see the whole picture. New version needs recompiling, but the error messages were somehow misleading.
And is it normal that it loses the licensing info?

Yes, am going to do that so I know what to expect.

When Visual Studio Code creates a new extension folder, the license key is lost (as it is in the folder where the activated license key is located)

The good thing is that it has a logical explanation. As I said earlier, am going to disable automatic updates in VSC so I can control this events.