Version 1.77 VS Code cause problem to TMS Web Core (Ide/Designer)

VS Code 1.77 failed to switch IDE/Designer WebCore command
I remove all VS code installation and re-install the last version of VS Code,
even with a new project there is this problem.

(I've tried on another device everything was ok until VS Code load the last version 1.77).


there's this error

Did you delete folders
and after that, install the latest v2.1 VSIX file?
With a clean install, there shouldn't be any issue.

Yes I delete the .VSCODE full folder and re-install WebCore from VSIX file (Who's not the last version)
And it's the same issue


I've tried twice on different devices and always the same problem !!!!!
With new project to !!


I've tried with a new device fresh os install without anything else (no addons)

From Scratch

  • VS Code installation (reboot)
  • Installation VSIX WebCore (reboot)

always the same problem.

Please Check this as soon as possible you can.
We can't create new form !!!


Can you please try the latest version v2.1.6240?

Yes it's already done.
But the last VSIX is not uptodate.
We try both from VS Code extension so with the last version V2.1.6240
and from VSIX (older version) and accept update to the last.
We try both from clean machine with new os without any older installation.
Try it to see from Windows 10-64 pro and last VS code 1.77.


I can conform that in these circumstances I also see the problem.
So, clearly, Visual Studio Code update broke something.
We will investigate.

I'm having the same problem trying to get webcore running on a new Mac Mini. Were you able to find a way forward with this?

Yes, we sent them the issue, they were able to reproduced it and fixed it, so will be available in next months release.

That's great, really appreciate all the hard work that goes into this, many thanks

This is the whole story:

And if you want, you can use VSCode Insiders, bearing in mind that is the latest from their repo. It works with that version :ok_hand:t2: