TMS Web core v2.2 Installation issue

Hi there,

I have a problem while installing the tms web core v2.2 under Delphi 10.4. Here is what I did:

  1. I uninstalled all the tms libraries including tms web core & FNC stuff.

  2. Then reboot my computer, and installed TMS Web core v2.2, and I did not see any issue while installing.

  3. Then I started the Delphi 10.4, I saw this:

  4. I clicked ok and saw this:

  5. After clicking several times, I went inside the environment and opened a demo project I created before, then I saw this:

I then uninstalled everything and tried again, I can still see the above issues.

Any advice would be appreciated!

Additional information : seems v2.2 works just well under Delphi 11. But it has issue under 10.4

I can only suspect this must be due to the patch level of your Delphi 10.4 version.
Did you install ALL updates & ALL patches?

Thanks Bruno for the reply.

I just installed all the patches & updates for my current 10.4 version:

Then I installed v2.2 again, and unluckily I can still see above issue.

Any other advice I can try?


100% sure there are no more old TMS WEB Core .BPL or .DCP files on your system?

Hi Bruno, just as you suggested, I cleared all TMS Web Core related BPL and DCP files, have searched in my system making sure they are all gone. Then I installed v2.2, I still saw that issue.

Anyway, thanks for the advice. I have downgraded to previous version v2.1.2, and will stay with this version for now.

This is very strange. We're investigating although, so far, we haven't received similar problem reports.
Do you have another machine where you can test this?

Hi Bruno, thanks for your response!

We have tried to installed V2.2 on my colleague's computer and we saw the same issue as I have on my computer. I think it is also worth to let you know he is using Delphi 10.4.2 too.


I can only think it must be due to a binary in compatibility between different 10.4.* versions.
What is the exact version of 10.4 you see under Help, About?

We are using Delphi 10.4 Update 2.
Embarcadero® RAD Studio 10.4 Version 27.0.40680.4203

Must be a binary incompatibility between the version with which we build BPLs on our server and your version (while Embarcadero promised binary compatibility). We'll need to investigate and this clearly might be non-trivial.

Thanks Bruno! We are looking forward to it!

Hi Bruno, just update here, I have installed and it works now. Thanks for fixing this!

1 Like