TMS VCL UI Pack 13.1.3.4 install problem

Smarty Setup, today:

  • TMS VCL UI Pack 13.1.3.4
    [14:43:10] - Delphi 10.2 Tokyo
    [14:43:10] - win32intel -> OK.
    [14:43:10] - win64intel -> FAILED.
    [14:43:10] - TMS VCL Grid Excel Bridge 3.2
    [14:43:10] - Delphi 10.2 Tokyo
    [14:43:10] - win32intel -> OK.
    [14:43:10] - win64intel -> FAILED.

Recently (about 20 days ago) I did a fresh installation. ( BDS -r parameter ). Is it really not possible to remove the installation errors that keep happening? I assume it's still the same principle of that error.

The most common cause is a configuration issue on your side for the Win64 compiler. To begin with, all library paths for Win64 need to be setup correct.
So, please verify your Win64 compile & library settings.
If a problem persists, send the log file so we can inspect.

I didn't change anything compared to the previous successful attempt. I don't know what settings we are talking about.
I can reset BDS again with -r, but this time it probably wouldn't help.
I am very careful. But periodically similar errors appear.
Is it possible to use Smart Setup to install the old TMS VCL UI Pack version that worked reliably for me the first time?

Hi,
Please send us the log of the error, without it, it is very difficult to know what is happening. I am personally installing and uninstalling VCL UI pack in win64 tens of times a day while testing some new smartsetup functionality, and I haven't seen any errors.

The current "D:\tms\Logs\logs.zip" is attached.

Still does not work. The previous version worked for me.
Between the previous and this version, I practically did not use the computer. Therefore, I don't know where I could make a mistake.
I have Alll Access version and the other components were installed correctly. Including the new FNC

[23:59:43] - TMS VCL UI Pack 13.1.3.4 -> FAILED.
[23:59:43] - Delphi 10.2 Tokyo -> FAILED.
[23:59:43] - win64intel -> FAILED.
[23:59:43] - TMS VCL Grid Excel Bridge 3.2 -> FAILED.
[23:59:43] - Delphi 10.2 Tokyo -> FAILED.
[23:59:43] - win64intel -> FAILED.
The current "D:\tms\Logs\logs.zip" is attached.

logs.zip (163.7 KB)

As you can see my Delphi version is Delphi 10.2 Tokyo.
It has already happened in the past that there was no problem in higher versions, but from my version and down, some code was wrong or was not properly updated in the installation. I personally dealt with it here earlier.
To Adrian's note: I have also successfully installed TMS VCL UI Pack many times so far.
But I had a problem with VCL with Excel Bridge in the days before Smart Setup. Not since then.

Hi,
This is a weird one. The error you are getting is:

D:\tms\Products\tms.vcl.uipack\AdvMenus.pas(33): error F2084: Internal Error: URW6300

But I've just tried it here with Tokyo, and it compiles correctly. Do you have all updates applied? (it should be 10.2.3). This looks like a bug in the compiler that was fixed in an update (because here with 10.2.3 it is compiling correctly)

My Delphi version:
Delphi 10.2 and C++Builder 10.2 Update 3