After installation Web Core 2.1 all indicates that 2.0.5 is installed

Dear Support Team!

After installation Web Core 2.1 all indicates that 2.0.5 is installed!
When I open the demo prject I receive the following message dialog.
After downloading, uninstall 2.1 I receive the following dialog again after opening the demo.
Where get I the correct version 2.1 or what was going wrong at installation time?

Thanks for advice.

Kind regards from Göttingen/Germany
Thorsten Hindermann

I have had this problem several times, when updating using the Subscription Manager.

When I did a complete uninstall and then dowload the latest version manually, everything is ok.

To avoid this kind of problem, always first uninstall via Windows Control Panel Add/Remove software and after this, verify in the Delphi IDE under Component / Install Packages that all references to TMS WEB Core packages are gone. After verifying all is clean, perform install of newest version.

Thank you, Bruno, for your advice. Yor solution worked completely for me after I rename the folder C:\Users\hinde\AppData\Local\tmssoftware\registered\TMS WEB Core RSXE14 into C:\Users\hinde\AppData\Local\tmssoftware\registered\TMS WEB Core RSXE14.old, because this folder was not removed by th uninstall process. After doing your described steps and the renaming I have now the Version in place.

Thanks for reporting.
Strange the uninstaller didn't remove the path.
Were other 3rd party components installed after TMS WEB Core?
Could it be some manual change was done to the path?

Could it be some manual change was done to the path?
No, I don't have manipulate the path or the content inside.
Were other 3rd party components installed after TMS WEB Core?
I don't remember exactly if I installed the MMX Explorer before or after TMS Web Core 2.0.5. But interfere MMX Explorer with TMS Web Core? :thinking:

I have not yet heard similar feedback but something to watch for indeed. We'll keep an eye on it.

I've run into this quite a bit. My guess is that the uninstaller does not work properly if you're not using the default paths. I put everything under C:\TMS, but the installer prefers the User's local application folder path (C:\Users\<user>\AppData\Local\...)

Once you change the path and then switch back to the default, the previous path is not removed from the search path and Delphi complains that it can't find a WEB Core BPL file when it's launched because it's looking on the previous path. I guess it finds it anyway b/c I haven't run into any issues once Delphi loads after this error comes up. I've only seen this happen (consistently) with WEB Core.

I suspect the uninstall of was not fully done.
Can you perform an uninstall of ALL TMS WEB Core parts from the Windows Control Panel Add/Remove software.
After uninstall, verify in the Delphi IDE there are no more references to TMS WEB Core. See under Component / Install Packages.
After there are no more references, do the install of the new version v2.0.1.4 on your clean Delphi IDE.

I've got several in the Windows Add/Remove panel that say it can't find the packages (because they're old and I previously just deleted the folders) and I'm not sure how to make these go away.

Next time I do an update I'll try this.

Just deleting folders is never a good idea.
Scan your hard disk for old versions of TMSWEBCorePkgDXE14., TMSWEBCorePkgLibDXE14., TMSWEBCorePkgDEDXE14.* and delete all old version files.

The upgrade from to was working as expected and "designed". Via control panel I remove the old version, started DELPHI and checked if alle references are gone. Also all two subdirs are gone without manually action from.
Installing the new version and all is working well and as designed.
For my case I see this issue as solved and for my opinion the issue can be closed. Thank you Bruno for your hints and help. I see that I have bet on the right horse with this controls and packages to develop my Windows desktop (and if needed Web) apps. :slight_smile:

1 Like