TMS Web core installation

TMS Web core installation

OS: Debian 10 LXDE 64bit
Lazarus 2.0.12 FPC 3.2.2

I'm trying to install the package I got:
I managed to install TMSVEBCorePkgDeLaz.lpk on Linux
I miss the visual components

I tried to work on win 7 64 bit but the result was the same.
On win 7 I took the TMSWebcoreLazarusDemo package published in the composition TMSWebcoreLazarusDemoFree1.5.4
From the demo I could install the TMSWEBCorePkgLibLaz.lpk package
And then I got all the components

How to do it on linux with purchased tools

change orginal TMSWebcoreLazarus/Component Library Source
TMSWebcoreLazarusDemo/Component Library Source

i was able to install the components and the startup was successful.

to work on linux you need to do:
change letter (upper case)

  1. diroctory Compile or (Linux64 to Linux):

#: chmod 777 -R TMSWEBCoreLazarus

Thanks for informing!

The original should also be able to be installed so that I can add a TMS FNC UI package
(TMSWebcoreLazarus/Component Library Source)

I'm not sure I understand. You have a specific issue with TMS FNC UI Pack?

now i can't install
tmswebcorefnccorepkg.lpk and tmswebcorefncuipackpkg.lpk
WEBLib.TMSFNCTypes.pas(132,7) Error: Incompatible types: got "AnsiString" expected "Int64"

I tried as instructed

but probably because I can't install the original
orginal TMSWebcoreLazarus/Component Library Source
already old
TMSWebcoreLazarusDemo/Component Library Source

I see these are all old FNC versions.
I'd recommend to use the latest versions. We haven't retested old FNC components versions against the newest Lazarus version. We always test the latest FNC component versions against the new IDE releases.

That's what I write:
I have the latest versions.

He won't install new versions for me.

The new version will not install Component Library Source

and when I take the old version from Demo Lazarus it installs it.

The new version reports the following error:
WEBLib.Utils.pas(23,3) Fatal: Cannot find System.Types used by WEBLib.Utils.

Compile package TMSWEBCorePkgLibLaz 1.8.2: Exit code 1, Errors: 1
WEBLib.Utils.pas(23,3) Fatal: Cannot find System.Types used by WEBLib.Utils.

Can you try to replace System.Types by Types?

Did you mean this?
System.Types -> Types
System.SysUtils -> SysUtils
System.DateUtils -> DateUtils
System.Classes -> Classes
System.IOUtils -> IOUtils (I can't find this anywhere)
Vcl.Controls -> Controls;

the problems continue

DayMonday = System.DateUtils.DayMonday;
DayTuesday = System.DateUtils.DayTuesday;
DayWednesday = System.DateUtils.DayWednesday;
DayThursday = System.DateUtils.DayThursday;
DayFriday = System.DateUtils.DayFriday;
DaySaturday = System.DateUtils.DaySaturday;
DaySunday = System.DateUtils.DaySunday;


We checked and will send incremental source updates.

Thanks Bruno,
I successfully installed TMSWEBCorePkgLibLaz.lpk

I have a problem with the installation: TMSWebCoreFNCCorePkg.lpk
TMS FNC Core for LCL

WEBLib.TMSFNCTypes.pas(132,7) Error: Incompatible types: got "AnsiString" expected "Int64"


I cleaned everything and reinstalled.
When I try to install tmswebcorefncuipackpkg.lpk

Report a problem WEBLib.Graphics

You have made changes to WEBLib.Graphics.pas

I had these mistakes:
WEBLib.Graphics.pas(245,17) Error: Identifier not found "TFPBrushStyle"
WEBLib.Graphics.pas(246,15) Error: Identifier not found "TFPPenStyle"

This was a change necessary for breaking changes in LCL with Lazarus 2.2.x.
I see you use an older version of Lazarus. Then comment these 2 lines.

Thanks Bruno,
Trying to install TMSWebCoreFNCCorePkg.lpk
there I added and TMSWebCore
I get different answers and I will report them, to help make this work.

Now this is the problem
system.pas(64,13) Error: Identifier not found "NativeInt"

Base types
SizeInt = NativeInt;
SizeUInt = NativeUInt;
PtrInt = NativeInt;
PtrUInt = NativeUInt;
ValSInt = NativeInt;
ValUInt = NativeUInt; strong text

it is also missing pas2js_rtl

After updating to the latest version are you still experiencing issues with FNC?

I still have a problem.

If the new version for TMS Web Core is coming soon, I will wait and explore more

To avoid confusion, can you please make a separate thread in the FNC category in the Support Center if it concerns an FNC product and provide more details here if it still concerns a TMS WEB Core product problem.

Thanks Bruno,
The TMS WEB Core is now installed correctly.