Lazarus not install TMSWebCoreFNCCorePkg.lpk and tmswebcorefncuipackpkg.lpk

OS: Debian 10 LXDE 64bit
Lazarus 2.1.0
FPC 3.2.2

TMS WEB Core for Lazarus

I tried to install TMSWebCoreFNCCorePkg.lpk and tmswebcorefncuipackpkg.lpk

system.pas(64,13) Error: Identifier not found "NativeInt"
system.pas(65,14) Error: Identifier not found "NativeUInt"

path: Core Source/RTL

unit system;
SizeInt = NativeInt;
SizeUInt = NativeUInt;
PtrInt = NativeInt;
PtrUInt = NativeUInt;
ValSInt = NativeInt;
ValUInt = NativeUInt;

Int64 = NativeInt; // only 53 bits at runtime
UInt64 = type NativeUInt unimplemented; // only 52 bits at runtime
QWord = type NativeUInt unimplemented; // only 52 bits at runtime
Comp = type NativeInt unimplemented;
NativeLargeInt = NativeInt;
NativeLargeUInt = NativeUInt;

You should NOT install TMSWebCoreFNCCorePkg.lpk but the install in the IDE is done with LCLTMSFNCCorePkg.lpk, LCLTMSFNCCorePkgDE.lpk. Same for FNC UI Pack with LCLTMSFNCUIPackPkg.lpk, LCLTMSFNCUIPackPkgDE.lpk,

Here it shows that the two tools can be combined, I will try this instruction:


Thanks Bruno,
I did it.
TMSFNCListEditor1:= TTMSFNCListEditor.Create(Self);
TMSFNCListEditor1.Color := clRed;
TMSFNCListEditor1.Parent := Self;

This component worked in a web browser

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.