System Error

I just updated to Web Core and now when I try to run any of the demo's I get "System Error.Code 740"  telling me that it need a privilege rise, version was working fine, no other changes was made.
Regards Ake.

Do you see TMSWebServerManager.exe running in the taskbar?

Does it help / change when you start the IDE as admin?

Just tried a few of the samples with Web Core on Tokyo. No issues here up to now...

As far as I can it is not, and when I try to start it, it start and immediately closing.
And I uninstall web core manually before install the new one, restarted the computer.

Do you see TMSWebServerManager.exe running in the taskbar?

Does it help / change when you start the IDE as admin?

When I run the IDE as admin it works. 

Did you install into any specific folder that might require admin privs to access files in this folder?

No.  It is the standard web core demo folders, all demos. 

I have a similar problem. I must start TMS Web server as Administrator and IDE as Administrator. But, even after that I get a blank page on any project I start running.

Do you see the project files being generated in subfolder TMSWeb\Debug ?

Do you see the TMS Web Server running in the Windows taskbar? If so, can you open it and see the logs what is happening?
Project files are generated, but it seams the path is wrong:


Web page is not shown.

But, if I search for the file manually then it's OK:

This will work OK.
  1. When you save the project in a different folder, is it working?
    2) Can you confirm you see the browser being launched and if so, when you see a blank page in the browser, did you check the console to see if there were any JavaScript errors?
1) No, it is not working. The problem exists even in demo projects. For example, when running from IDE it starts the following link:

Console reports:
Loading failed for the <script> with source “http://localhost:8000/TMSWeb_Multiform/index.html/TMSWeb_Multiform.js”. index.html:7
ReferenceError: rtl is not defined

But, if I manually correct the link to:

Then it works.

2) Yes, the browser starts but it only shows blank white page regardless of the content in the Form1.
Could you please show me the content of the file

TMS WEB Core\Demo\Basics\Multiform\Win32\Debug\TMSWebRunner.ini


HtmlPath=C:\Users\Public\Documents\tmssoftware\TMS WEB Core Demos\Basics\Multiform.\TMSWeb\Debug

The problem seems to be the trailing slash after index.html although I couldn't reproduce the issue with your config file.That's why I would like to ask: Does the browser show as the URL



Web browser (Firefox) shows:

Even if I delete trailing slash it is automatically added when I press enter to open the web page.

Look at to see if it helps

I only have Adblock Plus addon, and disabling it didn't help.

What happens if you are using the IE (Project/Options/Browser change from Default to Internet Explorer)?

Could you also please have a look at Tools/Options/TMS Web/Web Server Params? Does it look like
-s $(DefaultURL) $(OutputDir) ?

And are the params under Project/Options/Web Server Params empty?