System Error

When using IE (and Chrome) as default browser it works fine. Application is running as expected (there is no trailing slash in the URL).

I also noticed one more thing, not sure if it is related.. If the URL is

This works OK in IE and Chrome, but not in Firefox. If I change URL to a local file

This does not work in IE and Chrome, but works in Firefox..
Firefox allows to show the Web Core apps without webserver, the other browsers don't. That's why we added the whole web server stuff.

On my machine Firefox works perfectly and doesn't add the trailing slash. At this point I think that you have a problem with Firefox.

Could you reinstall Firefox? Or is too difficult to get back to all personal settings?
If you want to use Firefox without web server you can remove the web server under tools/options. Then Firefox should show a local file. With the other browsers this will not work.

I have another question: If you enable the single instance mode under project/options and run a Web Core demo in Firefox with a local file, does the TMS Debug Manager start without starting the IDE as admin?
Reinstalling Firefox did it! I don't know what Firefox settings caused this problem, but now there is no more trailing slash and everything works OK! Thank you!

I don't know how to enable single instance mode. What options exactly do I need to change?

See the "single tab in browser" setting under Project Options, explained on page 18-19 of the doc.

I changed "Single Tab in Browser" to True, but then it is not working. When I start the application from IDE, TMS WebServer starts running but the link is not added (WebServer is empty).

Back to where this thread started with the problem of running  Web Core demos. The
"problem" was solved by running the IDE as admin, that was not the case in  Web Core and versions before, is this now a new demand for Web Core and coming versions or is it just a temporarily flaw and gone in next version, my preference is to run IDE as a normal user. 

This is not an intended requirement and it is not desirable.
Is there anything special in the setup of your Windows user account that might cause this?
Is your Delphi setup for a single Windows user account or for all?
Are you using a Windows domain?

As far as I know, no special windows account, Delphi single user, no windows domain, Win 10 Pro version 1709.

May I ask in which directory you installed TMS Web?

In the standard directory where the installer put it, I never change suggested location for demos and components, it makes life easier in the long run. 

oops missed this  C:\Users\Ake\Documents\tmssoftware\TMS WEB Core RSXE11 

Could you please do a quick test?

1. Close TMSWebServer.exe (if it's open it would appear in the tray icon. Then right click the tray icon and choose "Exit").
2. Open windows command prompt (without admin rights)
3. Go to folder C:\Users\Ake\Documents\tmssoftware\TMS WEB Core RSXE11\TMSWebServer\bin
4. Run the following command-line (mind the dot at the end as a third parameter):

tmswebservermanager -s http://localhost:8000/dummytest .

And let me know if the command-line reports an error of if it finishes correctly and launches the TMSWebServer again (the tray icon should reappear).

Wagner R. Landgraf2018-07-10 13:54:39

No error as far I can see. It is a very short glimpse of the webserver window visible.
A very blurry picture:

The picture didn't appear, could you please resend it?