Invalid characters in file name .. Sirolo project problem bug

As I mention in another thread, today I upgraded TMS webcore to and had some problems.
In this case, whe I right click in the name of the project on the project pane, instead of the popup menu where usually appears "clean, compile, manage javascript libraries, Etc", now for any webcore project I only have a "invalid characters in file name" error message, Otherwise, the project compiles and runs, but that error hinder many actions.
Solution: reverted to 1.7, the latest Ancona from June 10 I think. Reverting to Ancona 1.7 solved all problems.

Today I reinstalled all WebCore 1.8 and the newly released FNC.
Did some tests and the "invalid characters in file name" only happen on webcore projects with Sirolo. Must be something related to Webcore, since normal windows projects don´t fail like that.

Just as reminder, it happens when right clicking on the project_name.web which in the screenshot is in bold, as active project. I can click on the branches without the error but the only place to do some things like manage javascript libraries is right clicking there.

I retested this here but I could not reproduce this.
Maybe you do not have a clean install of TMS WEB Core.
I suggest to perform an uninstall of anything TMS WEB Core via the Windows Control Panel (Add/Remove software) and then verify in the Delphi IDE all got uninstalled.
And after this, perform a fresh install on a clear Delphi environment.

I did all of that but it still fails. The good thing is that I think it is related somehow to the web browser selection on the TMS Web Core options, both in the main IDE options and in the Project options.
By examining the error message I sent previously, I remembered that it started doing something like that when I attempted to change the browser to firefox.
I managed to cause a similar error today by setting the browser to Firefox in the IDE and in the Project Web Core options. The app compiles but breaks when it starts with basically the same error, as in the screenshot.
In this case I can prevent the problem by setting the back the browser to Default in both places (project and ide options).
This second case is not the same but looks strikingly similar.
The original right click problem does not go away unless I uninstall Sirolo and replace it with the Ancona 1.7 version.
Probably when I was changing browsers some setting got stuck somewhere and didn´t reset to default. Searched in the registry, the app data folder and other usual places but didn´t find anything.

2021-08-03 16_53_09-allws - Delphi 10.4 - allws.dproj Built

Forgot to mention that it only works with "Default" and fails with any other option. Also, the WEB Core options do not accept to enter a custom path in the browser line, which is something I tried. It only accepts options from it´s dropdown list.

  1. What browsers do you have installed?
  2. Do you have another machine where this is also reproducible?

Browsers installed in my machine are Edge, Chrome, IE (unused) and Firefox. Just uninstalled Firefox and problem remains the same.
Don´t have another machine, but made a virtual VMware Win10, then installed Delphi Sydney CE, TMS web core, but it does not fail there. Sadly the virtual machine is painstakingly slow so it is not an option for actual work.
As you may recall my intention was to work with Lazarus but have not managed to make webcore and fnc work with it yet.

We might have found something. We applied a change in the code and this will be in the next update to be released.

Great when available will install and report back. Thanks!

The issue was solved with version 1.8.3. Now I can right click on the project and the options pop up menu show again without error messages.
Strangely, in the popup menu, browser options, firefox is grayed out even though is installed. But anyway it does not affect me, since I will be using the "default browser" option from now on.

There are different flavours of Firefox browsers. Which exact one do you have installed?

As far as I know, it is nothing special. I just browsed to the standard firefox download site and got it. In the Firefox "about" information, it says is V. 91.0 32bit. My windows 10 is 64 bit, latest update.

We are scanning the registry under "HKEY_CLASSES_ROOT" and look for "FirefoxHTML*".
If we can find this key, we open the "command" subkey and find then the default value.


I searched the registry with OOregeditor for "firefox"and the attached screenshot is what it found.
I noticed that the browser options in the TMS project popup have the "firefox development edition" enabled. But I just have installed the standard version. Also searched the disk for other versions but there is none.

2021-08-17 09_09_49-

We will check the code that identifies the regular Firefox vs Firefox developer edition

That is great. For starters I see my firefox is not 64 bits, but I never stopped thinking why windows 64 would select that version from the official firefox download site. That is one problem with automatic assumptions.

Please consider to add the "manual path input" option, meaning the ability for the developer to add a custom path to the preferred browser. We developers are savvy enough to find the exact browser executable name, and even though is great to have courtesy default path detection made for you, it somehow limits the possibilities, and as in this case, lead to unexpected behavior.
A manual input would complement the rest very good.

We are investigating the detection code.
Can it be you installed in the past a Firefox developer edition?
Could you send the appliocation.ini file from C:\Program Files (x86)\Mozilla Firefox for inspection?

Sure, here it is. (I added .txt to the name because this forum refused to upload .ini extension files)

application.ini.txt (895 Bytes)

Thanks for these details. We applied an improvement that will be included in the next release.