Rad Studio 10.2.3


Before I install it, do I need an updated flex cell for 10.2.3 (compared with 10.2.2)?



There is no need for an updated FlexCel, the current version works fine with 10.2.3


Apparently there is a little more to this....

After installing RadStudio 10.2.3, when I try to compile my FMX OSX project, I get errors that FMX.FlexCel.Core and FlexCel.XlsAdapter cannot be found.
What now?

I don't think this is related to 10.2.3: I've just tried the FMX OSX demos wih 10.2.3 and they worked fine here.

The fact that it is not finding the units seems to point to a wrong library path for OSX, but before trying to fix it manually, have you tried reinstalling FlexCel after installing 10.2.3?  This should fix the library path. If it doesn't, we'll have to look at the library path for OSX, but let's try reinstalling first.

Also, can you deploy a simple empty app to OSX with 10? 

I try to avoid doing any extra installs of flexcel, since I still have to run two different versions to Flexcel so I can support some older apps running on Delphi 5.  

Note that you can install FlexCel 6 and then 3 (in that order) without issues (and os still support delphi 5). Despite the common name, FlexCel 5/6 are a complete rewrite of FlexCel 3, so there are no shared units or anything that could cause trouble. You can see them as 2 different products (and FlexCel 5/6 doesn't support Delphi 5, so the oldest FlexCel version you have must be 2 or 3)

But in any case, if you prefer not to mess with this, can you tell me what is your library path for OS/X? (as shown in Step 3 of http://www.tmssoftware.biz/flexcel/doc/vcl/guides/installation-guide.html#step-by-step-manual-installation )
Do you have the FlexCel path in the list of paths for OSX?


You should have a line:

in there.
There are 2 possibilities:
1)Somehow that line got lost. If that is the case, you can add it back and it should work.
2)You didn't install OSX support when running the FlexCel setup. If 1) doesn't work, then I see no other option than reinstalling FlexCel 6, making sure you select OSX support in the setup.

Not possibility 2 - it worked fine on OSX until I installed the upgrade from 10.2.2 to 10.2.3.

But possibility 1 worked.  Apparently somehow that line was lost in upgrading.
I have problems with the installation