Problem installing in Lazarus

I Just purchased web core with the intention of using it in Lazarus.

Didn't have it installed, so grabbed a fresh download of lazarus 2.08 x86/x64 FPC 3.0.4 and followed the TMS video that states the simplicity of opening the package tmswebcorepkgliblaz.lpk and rebuilding the IDE.
It fails on rebuild, line 604,  bmp.LoadFromResourceName(FindClassHInstance(ClassInfo), ClassName);  It can't find identifier "FindClassHInstance".
Going through the lazarus pascal files, the function in mention is nowhere to be found.
Ok, so I read the documentation where is mentioned that WEB CORE runs on Lazarus 202,so I uninstalled everything, installed lazarus 2.02 x32 FPC 3.0.4 first, then all the TMS components.
In the pdf it says that I should install from tmswebcorepkgdelaz,lpk so I tried many combinations. 
Same thing. I commented the failing line in mention, then the compilation stops elsewhere. So I suspect that there must be something missing, perhaps a library reference, path, or perhaps another required package for this to work, considering that the install is absolutely clean and no other component is installed in the IDE, other than the stock installation.
Appreciate any help.  Didn't find anything in the documentation.

PC is Windows 10 x64 updated as of April 24,2020. 

Known small regression for Lazarus specifically in the latest release that has internally been fixed and this fix will be included in the next update.

To solve this immediately:
1) replace FindClassHInstance(ClassInfo) by HInstance

2) When the compiler complains about a TextHint property, remove this property

Great, I now installed Web core and the FCN packages in Lazarus 2.08 (removed 2.02 first).

It works, and now I will  dedicate some time to experiment and learn, specially when I get to the data part.
The basic programs run, however, before execution lazarus shows a message "can not copy lazarus\mingw\x86_64-win64...\libiconv-2.dll to lazarus\mingw\ecmascript5-...\libiconv-2.dll.  This does not happen with regular programs, only with the tms web core I have ran.

Probably some package in lazarus itself needs to be installed.

Thank you very much.

The libiconv-2 error was solved, by downloading the files that I found in this page,and basically just placing the dll where lazarus needs it. No more errors when starting.

In this page, the files link is in the step 5, where the guy mentions if 64 bit debugger is needed. The post is a bit old, but it worked.

Have another error with the FNCcore package, and programs, though. But am going to create a new thread if needed, after looking for documentation and trying to solve it.

It looks like an issue in the Lazarus 2.0.8 distribution

I reverted to lazarus 2.02 x32 and reinstalled all the components. All seem to work exactly the same as in the newer lazarus.

Everything installed, with the exception of tmswebcorefnccorepkg,lpk which i assume is the key to use any fnc component in a webcore application. 
The compilation errors that had on lazarus 2.08 are exactly happening with 2.02.  
Other than that, most demos work great, the FNC on one side and the Web core on the other side. Can not put any FNC on a web core form, I assumed that  it was possible or at least will be possible when the package is installed.

Errors so far when installing tmswebcorefnccorepkcg:  (there are also many warnings)
Compile package TMSWebCoreFNCCorePkg 0.0: Exit code 1, Errors: 3, Warnings: 2,2) Warning: Illegal compiler switch "IGNOREATTRIBUTES",2) Warning: Illegal compiler switch "IGNOREATTRIBUTES"
WEBLib.TMSFNCTypes.pas(87,7) Error: Incompatible types: got "AnsiString" expected "Int64"
WEBLib.TMSFNCTypes.pas(87,7) Error: Compile time expression: Wanted Boolean but got <erroneous type> at IF or ELSEIF
WEBLib.TMSFNCTypes.pas(95,19) Fatal: Cannot find WEBLib.Graphics used by WEBLib.TMSFNCTypes. Check if package TMSWEBCorePkgLibLaz is in the dependencies of package TMSWebCoreFNCCorePkg.

Perhaps it needs some tweaking in the code?
- The maps demo also shows an error "unable to initialize edge chromium" but didn't find reference or installer anywhere in the documentation or disk.
- some other demos had reference to a BETA package, just removed the reference and they worked, as well as others that needed to just remove a package reference.
- The blox demo does not find a blox toolbar, well among other minor issues.

It looks like you use an incorrect include file

If you compile with Lazarus, the define LCLLIB should be set so it skips line 87?

The package I was trying to install was unchanged.

Some of the things I found is that the conditional COMPILERVERSION > 22 is not recognized by the FPC. 
I substituted those statements with {$IF FPC_FULLVERSION > 20002}   
My compiler reports version 30004 so I assumed some correspondence with the number in the conditional above.  
After a number of changes, there is still a long list of errors though, it  seems that like WEBLib.TMSFNCTypes is referencing the wrong WEBlib.controls source, 
So am reverting to the original files in the hopes that you can fix something on your side.
Don't want to mess up the things that are working today.

If you have the correct {$I} file, the compiler should NOT see any defines like {$IF COMPILERVERSION < 23} 

You can clearly see that in the code:


and when you compile for LCL, the define VCLLIB is NOT set.

Your file should only have:

{$modeswitch ignoreattributes}

so, it should ONLY see code relevant to WEB & LCL

Ok, now am confused. I just ran the installers in this order:

1) The setup that unpacks another setup for lazarus, and some delphi ides.
2) Ran the setup for lazarus. Instead of default location, I use my own path as always, c:\dev\comp\tms\2020 (since I have ...\2004 iw installed too).
3) Ran the tms subscription manager and with it installed all the fnc packages under the indicated path. Also ran the delphi installers without actually installing on any IDE. 
4) installed lazarus, and inside lazarus the following,
5) installed webcore package. It had the problem that started this thread and was fixed with your advise.
6) try to install fncwebcore but it failed, so, installed all the remaining FNC components. 
7) now am trying to install the last package in mention, tmsfnccorewebcorepkg.lpk, which is under c:\dev\comp\tms\2020\TMS FNC Core. And yes, there is a bunch of delphi related files there, as well as  number of inc files. There is only one and it contains exactly what you wrote above.
I actually repeated the whole procedure, including uninstalling lazarus,wiping every folder and start over, with the purpose of cleanly changing lazarus version.
As far as I know, I didn't make any change to paths, so don't have any idea of how I ended up with the wrong inc file, or how the existing file references the wrong set. The source code only was changed under your advise.
Where should I look now?

Well, I give up...

I tried again, wiped everything including Lazarus and repeated the procedure, this time the target folder is different from the delphi components (c:\dev\complaz\tms). Installed all components there, unchecking the "install for delphi.." checkboxes on installer. 
Installed Lazarus in a different folder that it was before even though I completely deleted the previous dir, now is c:\dev\lazarus208x32x64).
Installed the components in the order of my previous post. When installing in the ide, webcore has exacty the same errors, changed the hinstance and commented the text properties that were preventing compilation. All installs well except for tmswebcorefnccorepkg,lpk which has exactly the same issues.  
Indeed the with the includes seem to define VCL, made a few changes (made a backup first) to make sure that it does point to LCL instead, but in the end it kept failing compile, so I just restored the modified files.
Now I have again the webcore part working fine, the fnc part as well, but webcore forms don't accept fnc components.
I noted that the installer anyway placed vcl and fmx in the folders. Perhaps a dedicated lazarus installer would be a good solution?
I guess my best hope is that you take a virgin computer installing in the same order and target folders I did, maybe you stump with the problem, because am sure you will have the same trouble. You'll never know if you don't try.
I should go back to developing and stopped debugging the components installation, am sure at some point an update will fix that installer, that should be as easy to install as the others.