Miletus is missing in obejctgalerie

I'm using Delphi 10.4 Sidney with TMS-WEB Core and I want create a new Miletus application but there is no enty in the objectrgalrie. What can I do

Thank you for help.

Here with the same setup (10.4 and it is shown. When I face issues like this i usually uninstall WebCore manually(!) completely and reinstall it then.
I use unins000.exe in the two install-directories (TMS WebCore and TMS WebCore RSXE13) to uninstall...


Thank you, it works. But only this works.

All FNC Packages are not loadable (connot find package)

I installed all FNC-components again. Same result.

And I cannot found then demo-projects in the old directory “C:\users\UName\Documents\tmssoftware

but in then UNVISIBLE directory “C:\users\uName\AppDate\Local\tmssoftware”


I am over 15 years tms-software customer, but I have never get a version that works ad hock. Every time

I have to invest some hours to get a functionality system.


Peter Helfrich

The demos are located as subfolder in the installation-folder of TMS FNC XXX here on my computer.

Regarding Installation of FNC-Components - did you also here try to uninstall them manually before re-installing ?

I also had hickups with installing the products within the subscription-manager sometimes. But since I uninstall manually the products and delete the setup.exe of the product in the appdata\local-dir before downloading/installing the new version everything runs fine.

May be ... but in contrast, most bug fixes are solved in 48 hour or less, and even some minor feature requests.
I use Delphi since 1996 and I'm sure I could fly twice around the world if I sum all the hours I've spent trying to figure out "wtf is goin'on here" within IDE, compiler & rtl. Some bugs I reported in 2019 hasn't been fixed yet in 10.4.2 - and I'm talking about 2 or 3 payed upgrade subscriptions after issues were reported, but who is counting?

Thank you for your answer !,

you’re right. The embarcadero support -in USA- sometimes just doesn't answer anymore.

TMS is there very much better!!

I was just annoyed. I’ll be better tomorrow again - as every tomorrow!

Best regards

Peter Helfrich


I have done so. Uninstalled the FNC-Components with unins000.exe from each directory.

The directories are deleted from the uninstaller. After this I installed FNC-Core

and all other FNC-Packs. Delphi starts without any Error message, but there are no FNC-Components.

I installed all components in “C:\users\UName\Documents\tmssoftware...

On the machine is also installed a Delphi Rio version. In both systems are no FNC-Components

will found.


Peter Helfrich


Are the Designtime-packages loaded ? Please check in Delphi Menu Components / install packages if the packages TMS FNC ... are listed and checked.

All FNC-Packages, I think, are listed but not checked because .bpl files “not found”

If I try compile i.e. TMSFNCCorePkgDEDXE13.dpk I get then errormessage

‘Never build’ Package ‘rtl’ must compiled

Thank you for your help, but I can only continue working tomorrow.

Peter Helfrich


I have had this problem in the past. Installing to the default folder causes very long entries in the Windows Path.and it is eventually too large. I always install to a shorter folder such as C:/\TMS\xxx

Are you sure you used the same user for all installations ?
What about the log-file of the installation - do you see any issues there ?
I usually put all the TMS-installations in a folder c:\dev... This also shortens the Windows-path if you have many Delphi versions and components...
I must set that path on every installation manually, but - this way I know where all the stuff is placed.

The same happened here. Since the first time I had this problem, I use subst t: c:\sistemas\libs\tmssoftware , and install all TMS Software in T:\xxxx .
(The subst must also be run at least once in Administrator context before using Subscription Manager or installing/reinstalling modules)

In another topic a user said he could solve it by installing today's FNC release.

Are you sure it is effectively v1.8.0.1 in the IDE?
Check under Help/About TMS WEB Core
When you install a new version, we recommend to always uninstall the previous version from the Windows Control Panel and then verify all is uninstalled from the IDE and only after verifying, install the newest version.


I tried the following:

  1. uninstalled all TMS-Packages with unins000.exe
  2. deleted all known TMS-subdirectories
  3. created a new directory C:\TMS as you recommended (I used environment variables in delphi until yesterday, it worked)
  4. deleted all not existing subdirectories in delphi’s searchpaths and librarypaths
  5. Install at first MSQTT for test (see attachment)
  6. Because there are many warnings I tried install the TMS-Business Core Library -> Errormessages; see attatchments

best regards

Peter Helfrich



You should not share your license-data in the log-file !

TMS MQTT installation had warnings, but did install and works fine, did I understand that correct.

The Log-File of TMS BCL in nearly empty - I can't see anything useful there.

Could you try to install it just for VCL32 platform - maybe there are platforms missing in your Delphi installation you want to install for ...?!?

I do not understand. You report an issue with TMS WEB Core and now bring information about TMS MQTT & TMS Business Subscription?
My answer referred to TMS WEB Core.

Continuing the discussion from Miletus is missing in obejctgalerie:

I thought I explained that with my approach.
Obviously it was not causally related to WEB-Core.
When a problem becomes too extensive for me, I take smaller steps first!
Anyway, thanks to your help, my path has put me on the right track or at least provided a functional system.
Thank you all.
Who cares: I believe that the TMS components were installed on my system under different accounts. That’s probably why the oversized path is too. Uninstall does not delete all files. After I have cleaned this up, everything works again.
I will probably have to write the account on a piece of paper in the future.