No 64bits support


I updated TMS Async component today, from to latest, using TMS Subscription Manager.

Component is available in the IDE in 32bits, but is not available anymore when selecting 64bits platform.

I didn"t have this issue before. I"m using C++ Builder 10 Seattle Update 1, Win7.

All other TMS components I have are ok in 64bits, only issue seems to be with Async32.

As a quick fix, could you please let us know where we can download previous versions?


Checked this with latest V1.9.4.2 released today: it's a bit strange but is working!

Components are still not available when selecting 64bits platform, so they cannot be placed in the form. However, if 32bits platform is selected, components can be placed, then when switching back to 64bits it builds the application without issue...
This problem is not present with TMS Component Pack. 

We do set the correct attribute for the component to appear in design-time for 64bit.
Could it be there is on your machine still an old version of the file that is then incorrectly used to compile the package? Can you scan for such file and make sure old versions are removed?

Hi Bruno,

No old version of file. I tried renaming the one in the Async32 directory, but it doesn't change anything on design time component after restart of the IDE, still shown as 32bits only.

I retested this here once more and I cannot see this problem.
Are you sure that within your IDE, you effectively have the latest version .BPL installed?

Can you check there are no leftover / old vacommpkgdxe9.bpl / vacommpkgdxe9.dcp files somewhere leftover on your hard disk? If so, please remove these old files and restart he IDE.