Install Failure TMS FNC UI Pack


Once again the TMS FNC UI Pack installation fails under Delphi 10.1 Berlin (with all patches).

After my report of the installation failing on, an update was posted (though no one at TMS ever bothered to inform us that this bug was fixed and that an update was available).

The TMS FNC UI Pack installer "succeeds" but no BPLs are created anywhere.

Trying to compile manually is perplexing as one cannot tell if one should use the XE10 or XE10_BETA or XE11 dproj file (tried all and all 3 fail to compile).

Could you please test your installers with Delphi 10.1, not only with 10.2 ? It is not such an old version that you should start ignoring it.

Very best regards,



There are no known issues with our installer. Please send us the log file so we can investigate this here.

I have the log files, but cannot figure how to attach them to my reply here ?


You can send them to with a link to this forum post

Same issue here.
I've both 10.1 and 10.2 (up to date) with (VCL) TMS Component Studio installed.
I was hoping to test FNC UI Pack for future FMX devs but I can't install the trial version either on 10.1 or on 10.2.


We have no issues at all installing the trial version, and we have not received any similar reports so far. Can you search in the library path for BPL files matching TMSFNCUIPack and in the installation folder as well? Please note that there are some issues with RAD Studio Tokyo and they have meanwhile patched this in the latest update 10.2.2, are you sure you have installed the correct update?

Have you found the problem? I've run into the same problem yesterday, and I solved it by replacing 'Self' with 'nil' in  TTMSFNCSearchEditButton and some other classes,  direct TPersistent descendants, not TComponent's. At any rate, the destructor takes care of freeing the memory allocated in the constructor, so even if 'Self' were compatible, it wouldn't have made sense in face of a explicit destruction.

On the other hand, TPersistent may not be a suitable parent, so I'd like to hear from you about my workaround while a definitive fix isn't in place.

The units needing the fix are


and their VCL counterparts.

They won't even compile so I think the offending lines can be easily found.

Tokyo 10.2.3 and FNC UI Pack

Thank you in advance for any feedback you may provide.

Kind regards,
Carlos Tré


We are currently reuploading a new version as we speak. Please await both TMS FNC Core and TMS FNC UI Pack updates. They will be available in the next hours.

Still not working, the setup program now complains about the FNC Core version, mistaking as being older than and refusing to proceed.


You might downloaded TMS FNC UI Pack while TMS FNC Core was still uploading. Please re-download both setups and try again.

Hi Mr. Scheldeman,

That was it. Oddly enough the TMS Subscription Manager detected both as being new versions ready for downloading. It seems to me it is right to think there is a flaw somewhere in this process that should be looked upon. 

Thankfully it didn't cause me any trouble as I am still in the exploration and discovery, otherwise there could have been serious damages as meanwhile I wouldn't have even been able to open and work with FNC UI Pack based forms.

Thank you


We know about this flaw and are discussing a way to integrate a "disabled for maintenance mode" while uploading FNC / FMX products that could easily take up a few hours when uploading.