TMSFNCGrid crashes Delphi 10.4.2 after TMS FNC Core Update

Hello, I just updated via TMS Subscription Manager: as soon as I'm opening projects containing TMSFNCGrid Delphi crashes (IDE just closes, no message).

Same happens if I create a new web project and I'm dropping a FNCGrid on a TWebForm...

Please wait for the update for TMS FNC UI Pack

OK, thanks - is FNC UI Pack update planned soon?
Meanwhile, is it OK to manually uninstall FNC Core and re-install

The IDE (D10.4.2 + D11.1) also crashes for me, and I'm sure there will be many more customers who will be confronted with this problem.

Shouldn't the update be withdrawn?
So there would be at least no more additional faulty installations.

We are uploading TMS FNC UI Pack as we speak. It should be available soon.

1 Like

So far, I've seen that WX Pack & AppTools updates are available. Waiting for UI Pack, then.
Meanwhile, doing a rollback and installing FNC Core makes Delphi usable again with FNCGrids.

TMS FNC UI Pack is available. Our apologies for the delay!

I can see UI Pack v3.7.3.1 visible in "My Products" page on website, but not in Subscription Manager ...sort of propagation delay?

Since the new version is not available in Subscription Manager,
I downloaded and installed version from "my products". It still crashes on me and FNC App still won't install.
Can it be that the root cause is "FNC Core" (see also message Incompatible TMS FNC Core ( installation found..)?

You have to uninstall all FNC products, and then install the updates starting with TMS FNC Core, please also redownload TMS FNC Core from the my products page.

I've just done the following

  • uninstalled all FNC products via Subscription Manager
  • all products' status is yellow into Subscription Manager after un-installation
  • downloaded FNC Core & FNC UI Pack from products page
  • manually installed FNC Core ==> status turns green into Subscription Manager, version number & date are updated
  • manually installed FNC UI Pack ==> status turns orange into Subscription Manager, version number & date stay at previous values under "uvailable" column
  • installed via Subscription Manager (in this order) Blox, Chart, Clou Pack, Dashboard Pack, WX Pack - all ok, statuses green
  • skipped (for now) installation of FNC Maps (I guess a new rev. is coming... so I'm a waiting a while)
  • finally, tried to install AppTools, but that's still not possible

By the way, FNCGrid & other FNC components back to working into my project, now... still something to fix in the installation chain and Subscription Manager, but not so bad... good work.

Monday morning update

  • Subscription Manager now realizes of new FNC UI Pack version ==> installed and working OK
  • Updated FNC AppTools to v1.0.0.4 via Subscription Manager ==> installed and working OK

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.