Component availability in IDE.


Just installed the new TMS FNC Websocket package and noticed that the TTMSFNCWebSocketServer & TTMSFNCWebSocketClient are not always available design time where I expected.

Issue 1: Using Delphi 10.4 start a new blank VCL application. Using the tool palette I can add a both TTMSFNCWebSocketServer & TTMSFNCWebSocketClient as expected. Now add a new TDataModule to the project, and see that TTMSFNCWebSocketServer & TTMSFNCWebSocketClient are not available to be dropped onto the TDatamodule.

Issue 2: Using Delphi 10.4 start a new Windows Service project. Neither TTMSFNCWebSocketServer & TTMSFNCWebSocketClient are available to be dropped onto the Unit1 form.

Neither issues are showstoppers, but just wanted to mention it.


This was reported before and we already applied some improvements. Can you check again with the newest version (

Well, to install the latest version of TMS FNC WebSocket I had to reinstall all FNC components it seems.
That's ok, but now my TMSSubscriptionManager2.exe will not install any FNC anymore due to a AV.

Every time I try to start installation of TMS FNC UI PACK, I get this:

TMS_Capture (6.8 KB)

Please see the attached for Call Stack ++

PS. This leaves me without any FNC component installed at the moment, I hope you can have a look at this issue now. So that I can continue my work as soon as possible.

Can you

  1. Delete files under c:\users<USERNAME>\AppData\Local\tmssoftware\TMS FNC WebSocket
  2. Download TMS Subscription Manager v2.2.0.0 after login on our website under Account/My Products and retry with this update

I have now deleted the files under:
c:\users<USERNAME>\AppData\Local\tmssoftware\TMS FNC WebSocket

And I have installed the v2.2.0.0 of the TMS Subscriptin Manager.

But trying to install the TMS FNC UI Pack, now gives me this error:


So the problem is with the TMS FNC UI Pack install?
Can you delete files under c:\users\AppData\Local\tmssoftware\TMS FNC UI Pack and then restart TMS Subscription Manager, redownload TMS FNC UI Pack registered version and run the install?

Yes, like I mentioned in my previous post I got the first error with the TMS FNC UI Pack.

I deleted those files now, but I'm unable to reinstall as I get "Maximum number of downloads for my IP address".

There are two packages that I'm unable to download due to maximum number of download. And that is:
TMS FNC UI Pack (as mentioned)
TMS FNC WebSocket

We reset the download counter

With download counter being reset, I was able to download the two packages.

I restarted the v2.2.0.0 TMS Subscription Manager, downloaded both packages. Then tried to install the TMS FNC UI Pack, but unfortunately I get this :


PS. the version of TMS FNC UI Pack being downloaded is : v according to the download manager.

I cannot see what could be causing this. Is this TMS Subscription Manager v2.2?
Is there any antivirus or websecurity tool running that might interfere?

What happens when you directly execute the installer via:
c:\users\<USERNAME>AppData\Local\tmssoftware\TMS FNC UI Pack\setup.exe

I can confirm I'm running TMS Subscription Manager v2.2
Everything else on this machine is as it has been for over a year now, no new antivirus, no new nothing I'm aware of.

Running the installer of TMS FNC UI Pack directly, it at least does not give me any AV's. But it reports that FNC Core is missing. I then went over to the TMS Subscription Manager, but here there are no FNC Core to select/install as far as I can see.
In my C:\Users\leo\AppData\Local\tmssoftware\TMS FNC Core I do have several FNC Core install files. I manually run setup and v2.8.6.0 installs successfully. Then I again try to install TMS FNC UI Pack from TMS Subscription Manager, but this still gives me AV. I then install TMS FNC UI Pack manually from disk, no AV but it complains that it needs FNC Core v2.9.0.1 ... the latest I have is v2.8.6.0

I do not have FNC Core v2.9.0.1, as far as I can see I do not have it available in my TMS Subscription Manager.

We'll look at why you do not see TMS FNC Core listed.
Meanwhile, you can download the latest TMS FNC Core latest version separately from our website under Account/My Products.

Ok, thank you.

I downloaded FNC Core directly, and installed it manually. That worked out fine.
In addition, after having FNC Core installed, I no longer see the AV in TMS Subscription Manager when starting the TMS FNC UI Pack installer! So it seems like that might have been the reason for the AV.

...and just now, it seems you where able to add the FNC Core available to my TMS Subscription Manager. Thank you!

We checked and normally also TMS FNC Core should be visible now in your TMS Subscription Manager. Can you verify?

Yes, I can confirm it's available now. Thank you.