Delphi 11.3 / VCL UI PACK


I have a problem with the licensed version (64bit).
When I compile my project under Delphi 11.3 I get errors when accessing the Delphi units.

With the trial version everything works. :shushing_face:

Now I have the trial version on my laptop and the licensed version on my PC.
Laptop compile ok. PC compile does not work.
When testing with the trial version on the PC, everything still worked as well.

Absolutely identical project.

The demo project I sent them can be compiled on both PC and laptop.
Where do I look for the problem. I have no starting point.

I have now loaded the licensed version on the laptop.
(Uninstall trial - install lic.ver.).
Now i have the same problem.
I can not compile the Project on the laptop.

What exact error message do you get?

[dcc64 Fataler Fehler] AdvCustomControl.pas(68): F2613 Unit 'Classes' nicht gefunden.
[dcc64 Fatal error] AdvCustomControl.pas(68): F2613 Unit 'Classes' not found.

I have now uninstalled and installed everything again.

Now I have also problems with the FNC packs.

When installing an error occurs.
With Delphi 11.2 everything was always ok.
This is now the first time that I install these packs with Delphi 11.3.

In the attachment are the log files.

One example, it has several such entries

C:\Program Files (x86)\Embarcadero\Studio\22.0\Bin\CodeGear.Delphi.Targets(412,5): error MSB6004: Der angegebene Speicherort der ausführbaren Datei der Aufgabe "C:\Program Files (x86)\Embarcadero\Studio\22.0\bin\dccaarm.exe" ist ungültig. [C:\Users\mak\AppData\Local\tmssoftware\registered\TMS FNC Chart\FMXTMSFNCChartPkgDXE14.dproj]


We have added more error reporting to our installers. Looking at your installation it seems some platforms have not been properly installed or configured. the Windows compilation was OK, so if you are not using the platforms that give errors then you can safely ignore the errors. If you plan on using all platforms available in the IDE, then you might need to reconfigure the platforms or reinstall the IDE.

I have now installed the entire RAD-Studio package on my PC.
I still get an error, but it looks like my projects are compiling correctly.

The problem from the error
[dcc64 Fatal error] AdvCustomControl.pas(68): F2613 Unit 'Classes' not found.
i could also fix it by re-bielding the "*.dproj ..."-Files.

This sort of error points to unit scope names setting that got wrong in your IDE