TMC VCL Ui Pack win32 Delphi 11 compile fails


I try to install the VCL UI Package on my brand new Delphi 11.
When I try to install from the IDE, I have the following error :
[dcc32 Fatal Error] FMXTMSFNCCorePkgDXE14.dpk(29): E2225
never-build package "'rtl'" must be recompiled

Win64 target works fine, it only occurs when I choose Win32

FMXTMSFNCCorePkgDXE14 is from TMS FNC Core, not from TMS VCL UI Pack.
These are two completely independent products, so it is unclear how this question relates to TMS VCL UI Pack.
Also, normally the installer does everything, i.e. also compiles packages and as such you should not need to compile from the IDE.

Hi Bruno,

Sorry for mistake. I was talking about VCLTMSFNCUPPaclkPkgDXE14

Results for both VCLTMSFNCUPPaclkPkgDXE14 and FMXTMSFNCCorePkgDXE14 are the same when I try to compile (or install) for Win32 target

As my colleague already mentioned, the installer automates the installation process. Is there a specific reason why you are manually installing the packages?

Yes : because after the automatic installer, designtime packages where not available in my IDE (error during launch...files missing). I conclude that the installer encounter an error (and I guess it's the same as in the IDE)

I can't figure out why I can't build thoses packages : all other packages works fine (TMS Web Core, Sparkle, Aurelius....)

Please send the installer generated log files under c:\users\USERNAME\AppData\Local\tmssoftware so we can inspect what exactly went wrong.

From your log file, I can only suspect there is some erratic TMSDEFS.INC file or you have some erratic defines in your IDE. Scan your full hard disk for old / incorrect TMSDEFS.INC files and make sure that only the one that is included in TMS VCL UI Pack is used (is in your library path) and make sure you did not use a define like ANDROID for compiling Win32 targets.

Please also send log files by direct email. Log files contain sensitive account information that should NOT be shared in public.

Thank you for your answer

I do not use any Android define.
I found many TMSDEFS.INC on my system, mostly on TMS Query Studio subdirs. all of them refers to ..\ (21 and 24 bytes) and finally land on tmssoftware\registered\TMS Query Studio\source (1392 bytes)

I also found one in TMS MemInsight but the one on TMS VCL UI Pack was before on the library path search. I tried to remove the TMS Meminsight from the library path. No change.

By the way, the other error was talking about missing "FMXTMSFNCCorePkgDXE14" so I tried to recompile it and I got this
[dcc32 Erreur] IOUtils.pas(19): E2003 Identificateur non déclaré : 'ConcatPaths'
Maybe I'm wrong but It looks like this unit is used only when LCLWEBLIB (which is defined by WEBLIB) is defined. I can't find where WEBLIB is defined.

It gets confusing to understand what exactly you are doing.
So, you try to compile TMS VCL UI Pack from the IDE? If so, which of the packages do you get what exact error with at what exact time?
If you want to manually install TMS VCL UI Pack from Delphi 11, you should open TMSVCLUIPackDXE14Group.GroupProj and build & install each of the packages in this group.
It should get compiled with TMSDEFS.INC that is included in the TMS VCL UI Pack source folder.

unfortunatly I have no TMSVCLUIPackDXE14Group.* files on my hard disk

Make sure you use the latest version of TMS VCL UI Pack with Delphi 11 support as this latest version has this file.

I just reinstall TMS VCM UI Pack ( / setup.exe dated march 15th).
No TMSVCLUIPackDXE14Group.GroupProj at all (i checked my full HD).
No *.GroupProj files inside the "tmssoftware\registred\TMS VCL UI" Pack folder

Of course, I have a TMS VCL UI Pack folder with files dated on march 15th (773 Bytes)

I tried to open the project group you sent me : error claiming a missing TMS FNC.
I then reinstalled TMS FNC Core.
Now the TMSVCLUIPackDXE14Group opens fine.
But when I try to compile it, I still have an compile error on IOUtils
[dcc32 Erreur] IOUtils.pas(19): E2003 Identificateur non déclaré : 'ConcatPaths'

I can only think you have an erratic IOUtils.pas on your system.
There is no code in System.IOUtils.pas with 'ConcatPaths' on line 19.
So, please cleanup old / incorrect *IOUtils.pas files on your system.

Thank you so much Bruno.

The pb was cause by an (very very) old unit called IOUtils on my system.
Now TMS VLC compile and install !

Have a nice evening

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.