TMS Component Pack Installation


I tried to install TMS Component Pack Installation

For all versions of rad studio from xe4 to xe 10.2 Tokyo everything went fine. But for XE 10.3 Rio
it started with compilation, but it took only 1 second for every package. The Installer reported no errors, but no installation was done at all.

This happened already the second time, before with the last version of 8.....

Sincerely Peter  


My problem is weird. I made a new project with only one TMS component added to the form. Compile is ok and run is ok. But when I open a old project (made in Seattle 10), an comile error keeps showing up saying "[ilink32 Error] Fatal: Unable to open file 'ADVPROGRESSBAR.OBJ'". I have a AdvProgressBar in the form. I searched my computer and couldn't find this AdvProgressBar.obj. But that new project form was ok without it. What should I change to get it right?
Thanks in advance!

In your project options, please configure your application to link with TMSDXE?.lib / TMSEXDXE?.lib

I am not sure if I really understand this.
Are you suggesting that I should add these two lib files to my project. My project is a package project. Or is there a step-by-step guide to walk me through how to confige my application to link with these two libs?

I way to configure this in code is via:

#pragma link "tmsdxe?.lib"
#pragma link "tmsexdxe?.lib"

Just downloaded and installed TMS UI Pack new release.
No error on installation.
Delphi 10.4.1 doesn't start anymore...

What exact error do you have?
How are you sure this is TMS VCL UI Pack related?

Reinstalled UI Pack with setup of dec '20, Delphi EDI opens normally.
Installed UI Pack last release. No error. Try to start Delphi EDI, seems to load.. stops on 'loading TMS UI Pack', flash screen disappear EDI not loaded.

We cannot reproduce this and have so far no similar problem reports.
What operating system is used?

Windows 10 64bit (OS Build 19042.746)
Embarcadero® Delphi 10.4 Version 27.0.38860.1461

  1. Do you have a different machine where you can test?
  2. Try to exclude packages being loaded by the IDE via the registry
    HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\22.0\Known Packages
    Remove packages from the list step by step in this order

and check if the IDE loads again and after removing which package this was.

We were able to find and fix the problem this way.
We have built our own package that uses TADVStringgrid.
We removed that from the registry. All error messages on loading IDE canceled, new build of package and added again to IDE.
A lot of work actually, but probably cannot be solved otherwise ...

When using depending packages, it is recommended to uninstall these before reinstalling TMS VCL UI Pack and then open & recompiling / reinstalling the depending packages.