Windows 11 installation problem FNC Maps

I have recently upgraded from Windows 10 to 11, reinstalled Delphi 10.3, then installed FNC core and FNC Maps. I did this using an administrator account in Windows 11. Delphi shows the FNC Core and FNC Maps as installed packages (Component > Installed packages...). All good so far.

But when I log into Windows with a standard account I can launch Delphi 10.3, but the FNC Core and Maps are not listed as an installed package.

This installation process worked OK on Windows 10.

What might I be doing wrong?

The package installation is per user. You'll need to install the package again for other users.

Thanks, I have now tried that, but the setup programme told me that the package was already installed and that I had to uninstall it (from the administrators account). Is this correct?


The registered version installs keys in HKEY_CURRENT_USER with the default installation path C:\Users[UserName]\AppData\Local\tmssoftware\registered

So if you have installed a package for that specific user that should not interfere with the installation for another user. If that is the case, you might need to check if there are no products installed anymore


I have now completed the installation of FNC Core and FNC Maps for the 'standard' windows user (maybe the version previously installed was left over from my earlier attempts, so I uninstalled that first).

When launching Delphi 10.3, the list of installed packages still does not contain FNC Core or FNC Maps (Component menu > install packages..).

And, the registry does not contain the expected 'HKEY_CURRENT_USER/Software/tmssoftware' folder.

When returning to the 'admin' Windows user, the packages are still installed OK in Delphi, and the registry for HKEY_CURRENT_USER has the installation directory you mentioned in /software/tmssoftware/TMS FNC Core/.. and ../TMS FNC Maps/..

Both Windows accounts are 'local' accounts.

Any suggestions? I don't want to use the administration account for normal day to day work for security reasons.


That's strange... Anyway, what you could do is just ignore the uninstall prompt, continue with the installation and check "Manual Compilation & Installation" and then just extract the resources. Then you can manually install in the IDE without corrupting the other installation.