Problems with Installation.

I had to reinstall Delphi (RAD Studio 10.2 Tokyo) and all components as I had to replace my hard drive.

I installed the following components:

  • TMS FNC Core
  • TMS FNC Chart
  • TMS FNC Cloud
  • TMS FNC Dashboard
  • TMS FNC Maps

When I started Delphi I received the following error messages:

  • Can't load package C:\Users\Public\Documents\Embarcadero\Studio\19.0\Bpl\TMSFNCDashboardPackPkgDEDXE11.bpl. The specified module could not be found.

  • Can't load package C:\Users\Public\Documents\Embarcadero\Studio\19.0\Bpl\TMSFNCUIPackPkgDEDXE11.bpl. The specified module could not be found.

So I installed those two packs again. Now I get:

  • Cannot load package 'TMSFNCUIPackPkgDEDXE11.' It contains unit 'FMX.TMSFNCGeneralDE', which is also contained in package 'TMSFNCCorePkgDEDXE11'.

The packs have not been modified in any way, so why am I getting these errors?


= Steve

The odd thing is I looked through the source code for the TMSFNCUIPackPkgDEDXE11 package and there's no reference to FMX.TMSFNCGeneralDE that I could see.

= Steve

FMX.TMSFNCGeneralDE is part of TMS FNC Core. It should be in that repository. If you installed components via the automated installer, you cannot install other packages manually on top, please either uninstall everything and retry with the automated installer, or click manual installation/compilation for every product and then use the packages. The log files will tell you what went wrong during compilation. They can be found in C:\Users\UserName\AppData\Local\tmssoftware\log

Hi Pieter,

I used the automated installers to install each package. I haven't done any manual installs.

I have tried uninstalling and reinstalling twice. Same result.

Please send us your logs

Now this is interesting. I tried uninstalling and installing it again and it failed. Then I uninstalled again but then installed the packages in a different order.

Previously, I was installing the FNC UI Pack last. This time I installed it immediately after the Core package. No more errors!

Attached are the log files for you reference.

= Steve

TMS FNC Chart_2.0.0.3.log (152.6 KB)
TMS FNC Cloud Pack_2.0.0.0.log (148.6 KB)
TMS FNC Core_2.8.4.4.log (182.9 KB)
TMS FNC Dashboard Pack_1.2.6.4.log (251.0 KB)
TMS FNC Maps_3.0.7.1.log (149.8 KB)
TMS FNC UI Pack_4.1.0.1.log (2.7 MB)

Well, that's very strange, the order shouldn't matter except TMS FNC Core needs to be installed first. Very strange!