WebCore / MyCloudData

I'm struggling with using MyCloudData with WebCore (using latest version of course). Both a VCL-App and also the pure JavaScript-example work fine.
I know that your time is very valuable and therefore in the last days tried all demos I found, read Holger's book and Wagners WebCore-Course twice, but didn't find any section about MyCloudData there.
Pretty sure my problem is the understanding the concept of the CallBack-Url since I get Error "91A App-Key not valid or Callback-Url not ok" after I try to login with the Login-Form.
Could someone please explain me what the proper way of setting the Callback-Url is ?
There are two places to set them. First one in the app and also on my Account on MyCloudData.net.
To what adresses(+ports) should both be set when testing locally or having the app copied on a server ?

Are there any other pitfalls I could have missed ?

Thanks/Regards, Tom
PS: Maybe one day Holger could create an article or a video on how to create/setup TMS MyCloudData.net with TMS WebCore because currently there is nothing similar to find anywhere...

From where do you run your web client application?
It is important that your callback URL in myCloudData settings is configured to point to the domain from where your web application is running and the callback URL you define under myCloudData.App.CallBackURL

Hello Bruno,
it works now when I run it locally. The problem was that I did not have *EXACTLY* the same CallbackURL in the app and in MyCloudData.net.
If I copy the same app to the public server, change the CallbackUrls matching the server adress and run it I find this Information on Browser-Console:
"SCRIPT5007: SCRIPT5007: Unable to get property 'processAuthData' of undefined or null reference".
But I definitely used exactly the same CallBackUrls.

Thanks/Regards, Tom
Hello Bruno,

I just tried it with the Google Chrome Browser and it seems to work there. Is it possible that it runs well on Chrome and not on Edge Browser ?

Thanks/Regards, Tom

It should be browser agnostic.
Do you get any error on Edge? Did you check the browser console?

Yes - see my message before...
"SCRIPT5007: SCRIPT5007: Unable to get property 'processAuthData' of undefined or null reference".
Hello Bruno, 
it runs on other computers with Edge-Browsers but not on my machine here. So the problem must be on my machine Setup/configuration.
Based on this error "SCRIPT5007: SCRIPT5007: Unable to get property 'processAuthData' of undefined or null reference". - do you have an idea where I should start to search.
I allready cleared all Browser Cache.
I also deactivated Norton Anti-Virus, because the machines that work have other AVs.

Thanks/Regards, Tom
Hello Bruno,

I also found these Items in my Browser log - I'm not quite familiar with theses issues - can you interprete them ?

Dynamische Skripts
Unknown script code (1)
var IDE = null;
var TMSWEBCoreClientIdentifier = "unknown";
var TMSWEBCoreOAuthCallback = "unknown";
function HandShake(cid){
  TMSWEBCoreClientIdentifier = cid;

Unknown script code (2)
 function processAuthData(access_token) {var event = new CustomEvent("oauthcallback", {
            detail: {
                 message: access_token
  bubbles: true,
  cancelable: true});


We are not aware of any Edge specific issues and haven't been able to reproduce this issue.
Can you please provide the version of TMS Web Core, Windows and Edge you are using so we can further investigate this?
Hi Bart,
thanks for getting back.
WebCore Vesion
Windows Home 1909 (Build 18363.752)
Edge: Standard-Version that comes with this Windows-Version
Do you think it could be related to some change on the compability-mode I made in the past in the windows-registry ?
Unfortunately i do not remember if and what i changed back then...
Do you know if I can somehow simply "reset" the Edge-Browser ?
Thanks/Regards, Tom

Can you try the folllowing?

- Press F12 to open developer tools
- On the Emulation tab, check if "Microsoft Edge" is selected in the User Agent String list.

Yes, it is Microsoft Edge.

Hello Bart,

for me it's perfectly fine not to use my Edge-Browser for that. I can use any other Browser and do the work I wanted to do !
I'm pretty sure that there is a lot of more important stuff than investigating a problem that only shows up on a single Computer.

Regards, Tom

Hi Tom,

That is true, the issue is most likely caused by a specific setting on your machine.
Thanks for confirming you have workaround by using a different brwoser.