TypeError: pas.System.$rtti['TArray'] is undefined

I keep getting this error:
TypeError: pas.System. $ Rtti ['TArray'] is undefined
Most of the time I find the unit that is involved and is responsible for the error.
But currently I have no idea where the error is coming from in my project.

Where can I search?
I use the "music"-Demo with only 2 own simple units and 1 TWebDataModule and 2 descendants from the TWebDataModule

Without knowing what is in your Pascal code, it is not possible to guess from here why this is happening.

I thought there might be a typical error.

I will look for points again, or try to limit the error by commenting out.

Today, the error is gone.
I made no changes.
Friday, I start/stop the Webserver multiple and nothing happens.

I have absolutely no idea what's going on here.
I had the same phenomena with my last inquiry.
I don't know which services I have to stop and start each time so that changes can be applied.
(In particular the testing, integration and deletion of units)

I suggest to start by ensuring your browser cache is cleared when the problem happens again.


I'm the same error...

In a clean project that runs ok, i add one TMFNC component and this error appears...

For example, the error appears on a form when i add a TTMSFNCTreeView component with any changes...

Then, if i remove this component of the webform the error continue...

I remove the error when i comment the uses that the component add automatically in the uses clause:

VCL.TMSFNCCustomControl, VCL.TMSFNCTreeViewBase, VCL.TMSFNCTreeViewData,
WEBLib.WebTools, WEBLib.JSON,

My version of TMSWebCore is:
TMS Web Core
Delphi 10.4

I use Firefox as a web navigator.

If i deply with Chrome the error message is diferent:
Uncaught TypeError: Cannot set properties of undefined (setting 'eltype') | TypeError: Cannot set properties of undefined (setting 'eltype') at Object.$mod.$implcode

Can you help me ?


I retested this here with the latest versions of FNC & TMS WEB Core and I cannot see such problem.
A default TTMSFNCTreeView on the form works fine as well as the demo the FNC TreeView.
Can you please check with the latest versions?


I try it in a new project and it runs fine...

But In my existing project, that it runs fine, when i add a new webform and add a new component TTMSFNCTreeView the error appears when i try to run the project...

I'm looking for the cause of error..........



I solved it by

  • Delete the file [ProjectName].identcache of the project folder
  • Delete Folders TMSWeb and Win32 also of the project folder