TMS WEB Core v


After installaton new version I have an error when application starts:

fMessage: "Unknown property: "OnRequest""
$ancestor: {$ancestor: {…}, $class: {…}, $classname: "Exception", $parent: {…}, $module: {…}, …}
$class: {$ancestor: {…}, $class: {…}, $classname: "EPropertyError", $parent: {…}, $module: {…}, …}
$classname: "EPropertyError"
$fullname: "TypInfo.EPropertyError"
$module: {$name: "TypInfo", $intfuseslist: Array(5), $impluseslist: null, $state: 5, $intfcode: f, …}
$name: "EPropertyError"
$parent: {$name: "TypInfo", $intfuseslist: Array(5), $impluseslist: null, $state: 5, $intfcode: f, …}
$rtti: {name: "EPropertyError", $module: {…}, class: {…}, members: {…}, names: Array(0), …}
__proto__: Object

Line 304 where error is throwing on my generated js file is:

        } catch($e){
          // do not call BeforeDestruction
          if (o.Destroy) o.Destroy();
line 304          throw $e;

Could you look what is wrong?

I see that this is problem with TXDataWebClient and event OnRequest


I have a problem too.

after the update, I get this error (inclided pas2js version info, maybe helps...)

Pas2JS Compiler version 1.4.16 [2019/10/15] for Win32 i386 / TMS WEB Core version v1.3.0.0[Error] XData.Web.Dataset.pas(308): identifier not found "usResolved"

code snipper of the error

procedure TXDataDataProxy.CheckBatchComplete(ABatch: TRecordUpdateBatch);
  BatchOK: Boolean;
  I: Integer;
  BatchOK := True;
  I := ABatch.List.Count - 1;
  While BatchOK and (I >= 0) do
    BatchOK := ABatch.List.Status in [usResolved, usResolveFailed];  // <-- Error here
  if BatchOK and Assigned(ABatch.OnResolve) then
    ABatch.OnResolve(Self, ABatch);

Please note that I already tried to uninstall + clean the BPL files and all directories + reinstall.

An update for TMS XData to go with TMS WEB Core v1.3 is required.
We are working to deliver that update asap.

ok, waiting... :)

Hi Thomasz and Dino,
We have today (December, 4th) released a new version of TMS XData which now supports TMS Web Core 1.3 and also Android 64-bit. 
Please remember to update also (in this order) TMS BCL, TMS Aurelius and TMS Sparkle before updating TMS XData.
Sorry for the inconvenience.

Is better but ... when you display MessageDialog with bootstrap ... the dialog is transparent
MessageDlg('test.', mtInformation, [], nil);

Could you check this?


We traced & solved this and we'll release an update to address this.

I confirm - i works perfectly.

After with MessageDlg is ok ... but now I have magic error:
1) Create new WEB Project
2) add TWebEdit on the form
3) Build ad open application in Chrome
4) press key F12
5)click on TWebEdit and clear signs using backspace.

After that I hav an error:
Uncaught TypeError: Cannot read property 'toString' of null
    at Object.HandleDoInput (WEBLib.Controls.pas:3202)
    at HTMLInputElement.cb (rtl.js:217)

It is magic for me :) Could you check this?


In v1.3.0.1, nothing was changed wrt controls or TWebEdit.
I can also not reproduce this here.

Did you do exactly what I described step by step , new project chrome, F12, backspace etc. ?

Out of interest I did exactly all steps you described here on D10.3.3 and WC1.3.0.1.
I don't get this or any error in Chrome...

Maybe my description step by step is wrong ... see movie

Could there be something with your browser identification?

Can you display in a memo:


and verify if your user agent does not contain Android?

Output from your command is:
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

Sorry, but I'm sure that it is problem with new WEB Core version, next test which I did was uninstall v1.3.0.1 and install and no problem this error now doesn't exist.

Any news concerning this issue?

I cannot reproduce this, no other user reported this and with the output of your navigator.userAgent, I cannot understand how you get this error.

We have added an extra check to the code, just assuming this will handle the problem on your machine, but of course, without being able to test/verify/reproduce this here.

i have same problem after update to 1.3 yesterday 6/12/19 , trace log F12 with chrome :


{fMessage: "Unknown property: "OnCreate"", fHelpContext: 0}fHelpContext: 0fMessage: "Unknown property: "OnCreate""proto: Object
c.$create @ rtl.js:299
CreateForm$3 @ WEBLib.Forms.pas:2167
$mod.$main @ RaonAppClient.dpr:60
doRun @ rtl.js:141
run @ rtl.js:156
(anonymous) @ RaonAppClient.html:25

How can this be reproduced?
I cannot see such error when running demos or when creating a new app and assigning the form's OnCreate event handler.