tms.vcl.uipack not showing up in C++ Builder

I installed TMS Smart Setup and installed the following packages (i am using Rad Studio 12.1):

  • tms.fnc.chart
  • tms.fnc.maps
  • tms.vcl.uipack

All packages are installed without problems. Although at startup the Splash-Screen of RAD Studio says, that all packages are correct installed.

The FNC-Components work fine with a Delphi and a C++-Builder Project.

The VCL-Components unfortunately only show up in a Delphi Project, but not in C++ Builder. I don't really know what the problem here is?

I also attached the log of the installation. (35.8 KB)

Thanks for informing us. This is indeed a bug in the VCL UI Pack distribution and we will fix it as soon as possible.
In the meantime, if you want to fix it manually, you can:

  1. Open the file "C:\Tools\tmssmartsetup\tms.vcl.uipack\packages\d12\TMSVCLUIPackGroup.groupproj" in Rad Studio
  2. For each of the projects in the group, right click it, select "Options..." and in the dialog, select Build->Delphi Compiler-> Output - C/C++
  3. Select "All Configurations" in the Target
  4. Select "C++ Output File Generation..." and then "Generate All C++ Builder files":

Repeat for all the packages in the group. After that, save, close delphi, and type tms build tms.vcl.uipack -full

After that, the packages should work in C++ builder.

When you don't have the delphi personality, add


inside the property group:

	<PropertyGroup Condition="'$(Base)'!=''">

for all *.dproj files.

Then do a full build from TMS Smart Setup

We installed the FNC-Components with the Smart Setup and stick with the old setup until the Bug int the VCL UI Pack-Smart Setup is fixed.

It's the easier solution for us right now.

But we are looking forward for the fixed version as Smart Setup is a really conveniant way to install all the components :slight_smile:

Hi, the bug with C++ Builder has been fixed. we are releasing an update today.

1 Like

Just tried it. Works perfect, thank you!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.