TMS Pack Version

Getting filesize incorrect when tryying to download the latest version using the TMS Subscription Manager. Have tried several times.

I have retested this from here and could not see an issue.
Do you see filesize in TMS Subscription Manager reported as 25.32MB?

Do you see a download under c:\users\USERNAME\AppData\local\tmssoftware\TMS Pack for FireMonkey?

Yes to both. I get the error message at about 25% through the download. This is the same of other updates due to be installed.

I am still unable to download on my main PC and am getting the same error. I have tried it on my notebook and it is ok so I guess it must be my end. I have turned off antivirus and firewall so not that. The trouble is that when I try to download it a second time I am getting the message that the maximum number of downloads have been exceeded for the day which doesn't help. This has only started happening with the last set of releases. Any ideas?

Is your IP address changing when you attempt additional downloads? 

I live in Spain and don't have a very good internet connections so I tried connecting via my personal hotspot on my iPhone which is quicker.

you encounter any issue with the download counter, you can always contact us to
reset it. 

Thanks Nancy. What are the implications of me downloadingg updates outside of the Subscription Manager?

There are no implications. You're free to choose between a download via our website or a download via TMS Subscription Manager.