TMS Echo kann nicht installiert werden

Delphi 11.1:
Während der Installation von "TMS ECHO" Version wird beim compilieren der Libraries die Installation abgebrochen.
Mit der Fehlermeldung:
Exception: Could not Execute command line. Exit Code 1

Alle Anderen Libraries werden ohne Probleme erstellt.
BIZ Version

I also get this error with Delphi 10.1 32 bit install.

Remembered that I had the problem before. TMS publishes each new library as soon as it is ready. You should only install the libraries when ALL new are released by TMS.
Only then can all of them be installed and work.

Always install/update the libraries in this order: TMS BCL, TMS Aurelius, TMS Sparkle, TMS XData, TMS Echo (or TMS RemoteDB).
If the problem persists, please send us the install log located in the setup folder inside the product installation directory.

install_2022_07_06.log (29.1 KB)
Hello Wagner,
I have installed the individual libraries as you mentioned. As with any update of the BIS all libraries can also be installed without any problems. Only the ECHO Library stops with an Error Message. The LOG file is attached.
Thx for help.

They were installed in that order - still get the error only with Echo.

I'll send the full log by e-mail, but this is the part of the log with the failure


"C:\DelphiLibs\TMS Echo\packages\dberlin\echo.dproj" (Build target) (1) ->
(_PasCoreCompile target) ->
C:\DelphiLibs\TMS Echo\source\core\Echo.Json.Converter.pas(122): error E2003: Undeclared identifier: 'NotifyPropertyWrite'
C:\DelphiLibs\TMS Echo\source\core\Echo.Json.Model.pas(9): error F2063: Could not compile used unit 'Echo.Json.Converter.pas'

0 Warning(s)
2 Error(s)

We have updated TMS Echo installer. You should see a new version number and a new download available. Please download the latest version, install it and let us know if it works ok now, thank you.

That was successful on Delphi 10.1

Thank you!

1 Like

Hello Wagner,
Echo was installed with the new version. However, I now get the following error message when compile a program (also with the ECHO Basic Demo):

[dcc32 Fataler Fehler] CommonUnit.pas(6): F2051 Unit Aurelius.Mapping.Optimization wurde mit einer unterschiedlichen Version von Bcl.Rtti.Utils.TRttiUtils compiliert

The compilation is canceled

An Screenshot as Appendix

I believe you have your project search path, or Delphi library path wrong, pointing to old/duplicatved files. Please review what you have in such library path. If you want, you can paste it here. Alternatively you can uninstall everything, make sure you remove any left overs in your Delphi IDE paths that mention any TMS BIZ product, then reinstall everything again.

I deleted all TMS Business files. Removed all Path entries and then reinstalled all Business packages. With the same result. The funny thing is that this error occurred ONLY after I installed the updates of the new versions of the TMS Business (Aurelius, Core, XData, Echo). I haven't changed path entries or other settings. Until the current update, Aurelius and all Aurelius tools ran flawlessly.

I did notice that the default installation folder for the Buisiness Core Library had changed with this version

"\TMS Busines Core Library"
"\TMS BIZ Core Library"

Could that have something to do with it?

No, because I use my own installation folders like
... (and so on)

There is not much secret in this. If Delphi complains about "compiled with different version", the binaries are incompatible. It's pointing to different binaries. Look for duplicated Bcl.Rtti.Utils.dcu and tmsbcl.dcp files in your hard disk. There must be something there.

I don't know where exactly the error lies. I searched the entire PC for the files, but I only have one version. I think it would be best if I redownload and install all Aurelius tools once. How can I set all tools back to "download" in the Subscription Manager? So that I can be sure to have all the latest files available.

You can delete the installers located in the "Data Folder":

Okay, I delete these folder.
But I can't download the Aurelius Tools. Because the maximum number of downloads are reached for date 08/07/2022
The last download was on 07/07/2022.... how long I have to wait for download?

After 24hrs max, you should be able to download again.