TadvMemo as SQL-Editor


In my Application I use some standard TMemo as input for SQL. It works put it has absolutely no comfort for input. So my intend was to use the TadvMemo as Input Control.

...is this possible? or can the component not used for such purposes.
maybe someone allready build a Styler for?

sorry my first thought was that the TadvMemo is a TScripter Compoment. Then I saw that it seems a basic TMS component. So feel free to move this topic if needed

TAdvMemo can show SQL syntax, yes among many others. It's possible, you can use the trial version and test it in your application.

Thank you, that's great.
hmm... can I run into troubles by installing the standalone TadvMemo Package. Does it replace or conflict in any way with the one that comes with the TScripter?

The trial version of TAdvMemo can't be combined with TMS Scripter (as TMS Scripter also uses internally TAdvMemo)

ok, thx.  ...and the purchased TAdvMemo? does it fully work with the scripter? what is the prefered way to install? must I remove scripter first? and after that have I to advise the scripter not to install its "light" internal version of the TadvMemo?  ...sorry for all the questions, just go sure before buying the TadvMemo.

Yes, you must remove scripter, install AdvMemo and then install TMS Scripter again. They share the same files, so Scripter will use AdvMemo files.

hmm... As I suggested there "are" conflicts with the scripter internal TadvMemo and the one which comes with the full TadvMemo.

As suggested I deinstalled the scripter first, then I install the full TadvMemo. After that I run the scripter setup. Then
I saw that the scripter package was not automatically activated. By
manually activating the package it shows me error of "package
tmsscriptervcl_xe2 can not load cause of the unit AdvMDD which is also
in Package advmemopkggdxe2"

Because I didn't found a switch in
the setup for a Install without the scripter internal TadvMemo, I decided to manually swep out scripter package from its
internal TadvMemo and compile/install the scripter packages manually.
Now seems to run. Following I will show you my steps I done.

1.) First I dropped the scripter subdirectory \advmemo with its content.
2.) Then I opened the tmsscripterxe2_packages.groupproj
3.) I compiled the runtime package. (tmsscripter)
4.) In the vcl package (tmsscriptervcl) I manually cleanout all units from the scripter subdir scripter\advmemo<br>5.) Then I compiled the vcl package and by asking I added the missing Packages Links from the TadvMemo
Then I opened the tmsscripterreg package and removed its internal
\scripter\advmemo contains and the \scripter\advmemo.res and compiled

It seems to work all now. But Was my work really necessary, or did I
simply miss a feature or switch from scripter setup or a rule by

The installer should detect the existing package and automatically perform the tasks you did. We will review the installing procedure, did you install the single TAdvMemo component or a pack that includes it?

I got the single TadvMemo from Shop. It came as a simple zip file and you have to install the package yourself.

Delphi XE2
- Unzip AdvMemoReg.ZIP into a new folder
- Add the new folder to the Delphi library path under Tools, Environment Options, Library
- From Delphi, choose File, Open & browser for AdvMemoPkgdXE2.dproj
- From the package editor, press Install & the components will appear under the tab "TMS Memo"

maybe a custom scripter Setup in which you can deactivate the TadvMemo will make it easier for future versions if the autodetect fails. ...But nevermind, with the clear and well structured scripter packages it's no brainer to do the changes/cleanout yourself ;)