Subscription Manager and Delphi 10.1

I was happy to see that the Subscription Manager showed installation of two packages for Delphi 10.1. already. The downside: It does not use the changed settings like a different BPL folder instead uses the default setting.

Best regards
Michael Jung. . 

I'm not sure what exactly you mean. The installer invokes MSBUILD and MSBUILD compiles packages to the default output path. This is a config from IDE/MSBUILD, not our installer.

Sorry for not beeing precise enough.

I use my own settings for the BPL / DCU etc folders, for example instead of
I use "E:\Studio\18.0\Bpl" by setting BDSCOMMONDIR to "E:\Studio\18.0" in the IDE options.
This worked in all Delphi versions so far.

Just installed upates with TMS Subscription Manager and all bpl's are in the public folder on the C: drive.installed.

Maybe a bug of Delphi 10.1 Berlin ?

I'm not aware that MSBUILD would not pickup correct settings.
What products within TMS Subscription Manager are you referring to?
Did you try to execute MSBUILD directly from the command line to see if it respects your modified output paths?

I admit that I never worked with MSBUILD directly yet, but I will try, test and come back. 

Just installed a new machine with XE7/XE8/10.0/10.1 and the installation log of TMS Pack for Firemonkey shows the standard path for BPL and not the overriden: So instead of "E:\Studio\15.0\Bpl" this @SET BDSCOMMONDIR=C:\Users\jung\Documents\Embarcadero\Studio\15.0 is used. 

Not sure what you mean. Our installers use the default output path defined by Delphi (to save having to add extra paths to the environment path). 

In Options you may override any of the enviroment variables like BDSCOMMONDIR

I can only guess this is an issue with how Embarcadero uses the environment variables & path settings for MSBUILD. As explained, we launch MSBUILD and expect MSBUILD to pickup settings properly
If this isn't the case on your machine, I'd suggest to contact Embarcadero about this.

FYI: I found the reason
Changing the path for BDSCOMMONDIR in options is not reflected in rsvars.bat which is used by MSBUILD. Submitted a bug report

Thanks for informing and we'll keep an eye on a solution from Embarcadero