Berlin 10.1 install

Component Pack: This always installs ok, except the paths and libraries are set only for 64-bit in C++ Builder. I need to manually set them for 32-bit.

Not a new problem, and not major, but is there a fix?



I cannot see this here. We do set the paths for both 32bit and 64bit.

I guess this must be an interference with something else on your machine.
Is this happening on multiple machines? Anything specific wrt your IDE setup?

It was a common problem on all my machines (at work, home, and a laptop) for every TMS install. Now I've installed Berlin on a new clean machine, and the TMS install does the same thing --- 32 bit paths are not set. Note that I have C++ Builder, not the full Rad Studio.

I make very few changes to Builder after install, mainly to the editor. I do not install the database options or the third-party tools, except Boost.

I double checked this and we do add the include path to:

if this key exists (and for a default C++Builder setup, this registry key should exist.

For 64bit, the path is added to:

Can you verify this key exists for the Windows user account via which you install our components. Make sure also that you use C++Builder with the same Windows user account.

yes, both keys exist

I cannot understand then why it would update the key for the 64bit path and not the key for the 32bit path? 

I did the following test:

1) uninstall tms using unis000.exe

2) in c++builder: tms paths are removed from 64 bit. paths are not removed from 32 bit (but show invalid paths)

3) in registry: tms paths are removed from both 32 and 64 bit registry keys

4) delete invalid paths from 32 bit

5) reinstall tms

6) in c++ builder: tms paths are in 64 bit. tms paths are not in 32 bit.

7) in registry: tms paths are in both 32 and 64 bit keys

So the registry paths are set correctly in both install and uninstall, but C++Builder paths are set only for 64 bit.


It is not clear what is special on your machine(s) that is causing this.
Is there something special with Windows user accounts?

I'd suggest to contact us by email and send us the installer log file so we can inspect it.

I am suffering from the same error.

When I was in Berlin 10.1 Update 2, I can not see the component.
When I run Rad Studio, it says that the bpl file does not exist.

This is not the same error. Please contact us by email & provide the installer generated log file under "My Documents" so we can inspect what went wrong. 9 out of 10 times, this is an issue with the Delphi setup, for example:
or antivirus software that blocks launching MSBUILD from setup.exe ...

I installed it successfully with the manual installation. Thank you for your advice.