Subscription Manager Access Violation attempting to install previous version

If I attempt to install a previously download version of the TMS VCL UI Pack for example by using the Subscription Manager ( and right clicking the "Downloaded" cell and picking the version I want to downgrade to, it causes an access violation:

Not sure what might be causing this.
Is this repeatedly reproducible? If so, what are the contents of folder
c:\users<USERNAME>\AppData\local\tmssoftware\TMS VCL UI Pack?

Yes, happens on any of my products every time (just tried it). There are over 30 versions available in that VCL UI folder, so to make it simple, here is the list in my TMS VCL Chart folder which also causes an access violation when attempting to pick an earlier version to install. First image is a right click in the manager, 2nd image is the folder contents:


What OS is this?
Can it be this setup.exe is somehow locked and can't be overwritten?
Can you run setup.exe and/or unzip files directly from this folder?

Windows10. I have no problem downloading a new version and installing using the manager, so the Setup can be overwritten just fine. I just can't select an old version. It immediately causes the access violation as soon as I click on one of the older ones. I have had to do this manually in the past for the VCL UI by deleting the Setup and extracting the setup form the zip due to this error.

Same thing happens on my Windows 10 notebook, so it is not machine dependent.

I run the manager out of my general TMS downloads folder:

Any specific 3rd party tool installed on these machines, in particular an antivirus/websecurity tool that might interfere?

Not that I know of. Just using Windows 10 security and antivirus. Can you give me any idea what the manager tool is trying to do at the address specified by the access violation? Maybe an earlier version of the manager tool left something in a corrupted state, maybe in the registry? Or maybe something related to my registration code? Not too long ago I couldn't even connect to TMS using the tool on one machine but could on another. I was instructed to update to which fixed that issue. So something was not quite right.

Now it shows me a different address for the exception... weird:

It will rename to and then extract to setup.exe from it.
With just this AV message, it is not really possible to decipher where the error comes from.
Can you take a backup of
and then run the tool again and then from the backup folder add old version files back to the product folders
and check again what happens?

Not sure I quite understand... did you miss a step? Do I clear out the tmssoftware folder after making a copy of it? Otherwise I don't see what this would do, so I added that step. It doesn't seem to get to the point where it renames anything to a name without the xyz version.

  1. Copied the tmssoftware folder
  2. Deleted all the files and subfolders out of tmssoftware
  3. Ran the tool and the downloaded column was empty for all products
  4. Closed the tool and copied just the product folders back to tmssoftware
  5. Ran the tool and attempted to select an older version
  6. AV occurred and neither the tmssoftware nor the product folder had added or renamed anything (checked while the AV was still on the screen).

If I delete the existing setup.exe file out of a product folder, the downloaded column is then blank for that product, and no older version can be selected (none listed).

Even before doing any of this, as well as after doing this, the AV is again at a new address, as if it changes each day, but not each time that day..

I asked to

-start from a clean folder c:\users\AppData\local\tmssoftware
-download a product
-add one old version zip file to a product folder (from your backup)
-check the select for an old version in TMS Subscription Manager
-verify what happens, if this works, add more old version ZIP files, till you see this error again and then report when it happened

  • Deleted everything out of the tmssoftware folder
  • Brought up the tool and downloaded TMS VCL Chart which is the available version.
  • Closed the tool, looked in the folder and it had and setup.exe
  • Copied from the backup folder into TMS VCL Chart folder
  • Brought up the tool and selected the version and immediately received the same AV as before and same address.
  • Checked the TMS VCL Chart folder and nothing new was added or renamed.

FWIW, I re-downloaded the tool, and now get a different AV address.

At least it is consistently inconsistent. :roll_eyes:

I have no idea what is causing this. I have not seen this before.
When we can allocate time, we'll look to build a new version with more diagnostics.

OK. FWIW, I just tried installing the tool on my old computer that we keep around for Delphi2007. The tool has never been installed on that machine, but is running Windows 10 Pro which is the only difference, vs Windows 10 Home. All were not originally Windows 10.

Brought up the tool and entered my credentials, downloaded the available TMS VCL Chart again (did not install of course). Did the same thing as above and copied the older version into the TMS VCL Chart folder and then attempted to select that version. Same access violation (different address).

Looking forward to seeing what you can provide on this for troubleshooting. Not urgent.