Param 37 not supported

Have in SQL Server field type Decimal(18,2). Using RemoteDB.

When trying to post record where field value has changed, get ODBC error Param 37 not supported.

Tried to change display and edit formats in dataset to "0.00" but it didn't help.

Which database-access component are you using to connect to SQL Server? Have you tried to update your SQL Server client in the computer where your RemoteDB server is located, to see if it solves the issue?

Using native MSSQL. Just updated Sql Server Client, it solved this AutoInc problem few days ago

Problem exist also when RemoteDB is running in development machine at localhost. In development machine is also Sql Server Client just updated.

Could you please then provide exact steps and/or sample project so we can consistently reproduce it on our side?

Send you in mail both server and client projects

Thank you for the projects. They were very useful. We could reproduce and fix the issue. Next RemoteDB update will include the fix.

Great! Thanks :)

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.