RemoteDB / AutoInc field

Evaluating RemoteDB and find out that it doesn't handle autoinc key field automatically like XData does.

When posting record to MSSQL database, get message that "id" field is required. In TXDataset is KeyField set to "id" and AutoAplly := true.

How is key field what's autoinc handled in RemoteDB?

Please try to set the Required property of field id to false.

Already tryed that. Get this message after post:

That is a very generic error. We need to reproduce the issue on our side. In any case, I'd recommend you install the SQL Server client to the latest version to see if the error disappears.

Installed this to development pc. Compiled RemoteDB server app again and downloaded it to EC2 instance. Same error continues.

Tested what value id field has before post and it's null. Tested also to add it to '-1' but same error continues.

Can you reproduce it in your local machine? Have you updated the SQL Server client in your EC2 computer?

Managed to update it to EC2 also and it started working. Thank you for help, again:)

I'am running RemoteDB Server in EC2 with load balancer and connection is HTTPS. Was little worried if it works with this setup but seems to work.

1 Like

After updating to latest version of RemoteDB and Aurelius, after posting new record to dataset get this error:


Id field is AutoInc at SQL Server.

I get this error with all dataset at project after updating components.

I send to you project where this exists earlier (param 37 problem), if you still have it, you can reproduce this with it. I can also send it again if necessary.

Error comes with server at EC2 instance and also with local machine.

Ok, should have use my own brains first, managed to solve problem :slight_smile:

Set in dataset id field required property to false, seems to work now.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.