Query and Blob Field

I'm have the following Query


when  executed  I get the following exception: "InsDatDEcH: Field 'BINDATA' is of an unknown type"

Does TXDataSet and REmoteDB supports inserting/reading blobl fields?

Using UNIDAC/FireBird

"BINDATA                        BLOB SUB_TYPE 0 SEGMENT SIZE 80"

Thanks in Advance,

Omar Zelaya


yes, it does support it. Can you provide detailed code about how you are executing the query? What is InsDataDEcH? Is "BINDATA" he's referring to the field or the param? Maybe you are not setting Param.DataType somehow?

I have also a problem with BlobField. How can I set the value of the blobfield (RemoteDB)? A function like Loadfromstream are not available.

Why you say LoadFromStream is not available? TXDataset is a regular dataset which has the same TField objects that are common to all datasets, including TBlobField, for example. The mechanism of dealing with field values is the same.

Testing again with TXDataSet, inserting a row on a table that contains a BLOB FIELD I get the following error when I call ExecSQL.

Dynamic SQL Error
SQL error code = -303 feature is not supported BLOB and array data types are not supported for move operation.

Thanks in advance,

Omar Zelaya

Hi Omar,

I use RemoteDB with Blobfield as follows:

XDatasetDoc.SQL.Add('insert into table1 (name, surname, street, notice, typ)');
XDatasetDoc.SQL.Add('('''+Name+''', '''+Surname''','''+Street+''', :Notiz, '+Typ+')');
XDatasetDoc.ParamByName('Notiz').LoadFromFile(FileUpload.FileName, ftBlob);

Instead of LoadFromField, of course, any other assignment can be made

Best wishes Karl-Heinz
I forgot to mention i'm using TGenericDatabase for connection.

Thanks in advance,

Omar Zelaya

Again, can you provide detailed code? We can't guess what's going on.

Have you tried the provided suggestions?

Using FireBird and UniDAC, I have also tried to set the Parameter type to ftBlob also tried using AsBlob with no succes.

On UniDAC forums "It return this error if parameter for blob is ftString."

Thanks in advance,

Omar Zelaya

Please provide the code. Steps to reproduce. 


Fixed now, there was a text blob field on the table and needed to use AsMemo instead of AsString.