No form designer in VSC 1.64.2

I installed the latest version(1.64.2) VSC and TMS Web Core extension on MacOS(Big Sur) . When I created a new TMS Web Application and selected a .pas file, I only saw the Code Editor window. I tried to toggle to Form Designer via CTL+F12, but no effect.Then I tried on Windows 10, the problem still remains.

I have no idea how to active the Form Designer, is there something wrong I did??

I see no project has been loaded. Please, can you try the following?

  • Close VSC
  • Open it again
  • If the folder you are working on is not open, please, open that folder and send me another shot

Also, please, let me know about the locale you are working on, so we can try to reproduce the issue.


Not sure if it helps with your issue, but I had a similar issue in the past. I uninstalled the FNC-Components from VSC and re-installed them and then it was fine again...

I closed and reopened but nothing changed, the folder path is 'icloud disk\document\work\YingDan\VSC\TryElectron', screenshot is below

I am working on Big Sur on a MacBook Air 2014, the OS languge is Simplified Chinese, VSC version is 1.64.2, TMS Web Core for VSC version is 1.9.5379, Language pack extension for Chinese (Simplified) and Delphi Extension Pack 2.0, NO other components.



Thank you very much @Feichtenschlager_Thomas but there is some differences, I did not install any Components except TMS Web Core extension from Extension Store.

From the shots you sent me, it may happen that other extension is taking over the .pas files, and not OmniPascal. Would be possible for you to disable extensions like DelphiLSP and Pascal and try again?

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.