Invalid License


I just bought and ALL-ACCESS subscription, and installed some packages.

The web core installation is gone fine, but when I start RIO DX, the IDE complains about it cannot load the design time package for web core.

I am getting the following error:

Did you install a trial before and if so, did you uninstall before and remove the key

HKEY_CURRENT_USER\Software\TMSSoftware\TMS Web Core\License?
Hmm the image did't show up...

So I am getting a popup with the following text:

Registration procedure, Tms@Web@Ide@Register.Register in package <package file path>\RSX12\Win32\TMSWEBCorePkgDEDXE12.bpl raised exception class ETMSWebIDEPas2JS: Invalid TMS WEB Core License

How can I fix this?

Computer: Apple Macbook Pro,
OS Parallels Desktop VM, Windows 10 Pro x64,
IDE RadStudio 10.3 Pro, DX.

Best Regards

This key is empty.....

This the first installation of Web core, there was no trial or other installed before.

Best Regards
In the registry, the "Code" subkey is contains my ALL-ACCESS regcode, the License subkey is empty.

Best Regards

Do you run the installer with the same Windows user account as the one with which you run Delphi?

There is only one account in this Windows VM.

Best Regards

When you run the registered version TMS WEB Core installer, it should have set this key.
Is there something special with your Windows machine name? Windows user account name?
Given this is sensitive information, it would be better to contact us by direct email.

I think I reproduced the problem

The first time I was install both Lazarus and Radstudio version, and both setup was opened automatically by the main installer.

And this was the failed installation.
After that I reinstall Radstudio version, by running only the radstudio installer, and it was installed fine and add my license code to the registry.

I cleaned up this, and run the unified installer as first time, and ask both Lazarus and Radstudio version to install.
It is opened both setups i finish the Radstudio first and after the lazarus, and the installation was failed again.

Best Regards

After the succesful RadStudio install, I ran the Lazarus setup and it clears the license again! It even don't ask my registration datas only install the packs, seems like it works as a trial one.....

Mabe this is the problem.

That is very strange and so far I did not encounter this. I will discuss this with the team responsible for the installer.

We will verify. In fact, when you have Delphi installed, it is not necessary to run the installer for Lazarus as the installer for Delphi also deploys the Lazarus packages needed for completing install manually in the Lazarus IDE.

I had the same issue.  By not installing Lazarus after the Windows installation, the problem seems to be solved.

I meant to say:

I had the same issue.  By not installing Lazarus after the RAD Studio installation, the problem seems to be solved.