Installing on Delphi 10.2 Tokyo

I am having trouble installing the TMS VCL Component pack V8.5.4.0 in Delphi 10.2 (Tokyo). The install appears to run with everything compiling and Delphi 10.2 is detected by the installer. However when I run Delphi nothing has been installed. No components and nothing in the Install Package List.

The VCL Cloud Pack and all my FMX components have installed correctly.

Have I missed something or is there a problem with this install with Delphi 10.2


Can you send the install.log file (TMS Component
Pack_8.5.4.0.log) that should have been generated in your "\My
documents" folder for investigation.

Log file sent as an attachment to

What was the resolution for this ? I had the same problem with 10.1 (Berlin). I'm logged in as myself but the TMS installer has to be run using elevated privileges of another user. If I run RAD Studio with the elevated privileges I can see that the components were added to that user but they aren't installed for me.

For whatever reason, this wasn't a problem with XE7.

The solution was to re-download the
software. I had downloaded it on the day it was released. It was subsequently updated with the same version number without anybody being informed .

Re-downloaded the installer and, unfortunately, that didn't work for me.

Can you clarify 'that didn't work for me'?

What exact issue do you encounter?

When I run the installer, I have to right click and use the 'Run as Administrator' option since my user account does not have admin privileges. Installer runs and compiles everything but when I run RAD Studio, the TMS components are not there. If I run RAD Studio as an admin (right click and choose 'Run as Administrator') the TMS components are available.

You should start the installer using the same Windows user account as the one with which you installed Delphi (so, NOT via Run As Administrator). When the installer started (as the current Windows user account), it will ask for admin privileges to be able to write to certain folders and update certain registry settings.

Same result (I actually tried it both ways at this point). RAD Studio was installed in same manner - start the installer as current user then get prompted for admin privileges.

Please contact us by email and include in the email the installer generated log file (under \My Documents) so we can inspect what went wrong.