Installation Verona 1.1 under Lazarus

I had / have the following issues when installing under Windows / Lazarus (1.8.) :

Package pas2js_rtl.lpk :

In file hotreloadclient.pas in function THotReload.doStatus()

I had to replace 




Package tmswebcorepkgliblaz.lpk

In file \Component Library Source\js.pas I had to uncomment the

{$ASMMODE intel}

compiler direction

Package tmswebcore.lpk

Package TMSWebCore 0.0: Executing command before: missing executable "", Errors: 1
Panic: internal error: missing executable ""

That might be a configuration problem in my Lazarus installation(?)

With best regards

pas2js_rtl.lpk is not a package we deliver.

We tested from Lazarus 1.8.4. Can you please use this version.

Just checked the Lazarus version, it is version 1.8.4

\Core Source\RTL<span style="font-weight: 700;">pas2js_rtl.lpk

is part of the installation. Its a required package for tmswebcore.lpk.

Maybe I'm totally wrong in how to install WEB Core under Lazarus. Could you pls. provide a short installation note?

Best regards

You only need to open this package once and NOT compile it. It is just opening to get it registered by the Lazarus IDE.

I can't make it run.

I made a fresh Lazarus 1.8.4 /Win32 installation installed the packages


The /Compiler/pas2js.exe is in the Path

When I open a new TMS Web Core Application there is a warning showing up :

"The current FPC has no config file. It will probably miss some units. Check your installation of fpc"

I don't understand this message, the Lazarus installation is compiling and running

When confirming this message, a new web application will be created, but I can't run it. The message is :

Package TMSWebCore 0.0: Executing command before: missing executable "", Errors: 1
Panic: internal error: missing executable ""

Can you pls provide a Lazarus installation procedure to make it possible to let a simple empty form application run?

With best regards
need to be compiled & installed in the IDE.

Under the settings for TMS WEB Core, the path for the TMSWEBCompiler.exe needs to be set and the library paths.

This are the default TMS Web Core settings :

Web Compiler : $(TMSWebDir)/Compiler/$MakeExe(IDE,tmswebcompiler)

In my case the pas2js.exe is in

C:\Lazarus\Components\TMS WEB Core\\Compiler

How I have to configure my settings? I really don't understand the meaning of the default configuration string. Its not looking like just the path to the web compiler exe...

Which libraries I have to put into the Library path? The path is empty by default.

Well, even I don't understand the default configuration string for TMS Web Core settings, I entered the path to the pas2js.exe :

C:\Lazarus\Components\TMS WEB Core\\Compiler\pas2js.exe

All other configuration settings are with their defualt values.

When compiling a new empty TMS Web Core application I get the error message :

Fatal: Only one Pascal file is supported, but got "C:\Lazarus\Components\TMS WEB Core\\HtmlOutputDir:html" and "/CompilerBin:C:\Lazarus\Components\TMS WEB Core\\Compiler\libpas2js.dll".

How to solve that?

Best regards

As I explained, the compiler you need to setup is TMSWEBCompiler.exe.
pas2js.exe is NOT directly used.

Well, that might be the problem, there is no TMSWEBCompiler.exe in the Lazarus installation. Sorry for not reading your previous messages carefully enough, you mentioned that already in one of your earlier messages.

My understanding so far was, that the pas2js.exe precompiles the pascal code to java script.

Best regards - merry christmas and happy holidays

TMSWEBCompiler.exe internally uses pas2js but it performs extra needed steps.

This EXE should be in the CommandLineCompiler folder.

There is no CommandLineCompiler folder

We will investigate what could cause this. Is there an antivirus tool active on your system that could have blocked this EXE?Bruno Fierens2018-12-26 09:49:13

Hm, its a WIndows 8.1 with an active Windows Defender... But there was a  false positive Alarm as reported on December 20. I will switch it off and run the installer again.

Makes no difference - no TMSWEBCompiler.exe

@ Ulrich Groffy

Do you need to be on all access to try the Linux version? I don't see the download available ? I would try to set it up.

No, Lazarus beta level support is in the TMS WEB Core standalone registered version.

I also tried an installer for a delphi DXE12 (comunity edition) but couldn't find the TMSWEBCompiler.exe

When can I expect a new installer version? Or can you pls provide the missing files to me? 

Best regards

Is that TMSWEBCompiler.exe Lazarus specific or in every installation for all supported IDEs ?

Just tried the TMSWebCore installer from today, no difference

TMSWEBCompiler.exe is not Lazarus specific. It is one EXE that is used both for Delphi & Lazarus.