TMS Web Core 1.7 - cannot use in Lazarus


I tried TMS Web Core 1.7 in last days using Lazarus 2.0.12

I succeded in install and compile a simple new project and some demos.

But, in almost any case where I tried to do something more "real" like to add an event (OnFormShow, OnClick) there are some errors notified right after the action.

It is opening a windows telling the web.pas or other has some missing properties.

Actually, it is like there are 2 web.pas files in 2 different installaction directories ans those 2 are very different from each other (also as version) and they are conflicting.

If I "rename" one of this (keeping the most updated code), the code for the event is added but then I cannot compile.

Also after istallation of version 1.7, reported version is 1.5.

For me is still not clear how TMS Web core is working ( this is not a problem ) but I can feel some ambiguity because of some duplicated name units (like web.pas) in different folders like
"Component Library Source" and "Core Source\RTL".

It seems that the version in the latter dir is much older and anyway pas2js is complaining, it is not using the correct web.pas I think.

How can be resolved?


Folder "Component Library Source" is for design-time.
Folder "Core Source" is what is compiles against.
Make sure to add "Component Library Source" to your IDE library path.

Thanks for you answer, but what is the exact place to configure that?

Something went wrong when you created your TMS Web Core project, your main form should derive from TWebForm and not from TForm. Try to create a new project of type "TMS Web Core Application"

Uhm, I don't know. I rechecked if it was due to my mistake but I correctly selected to create a new "TMS Web Core" project.

I'm attaching some screenshosts.


The only two packages that should be installed are

Try to fully remove this other package from the IDE.

I'm not hte master here, but it looks like installation is correct, but I reinstalled from scratch.
I noticed , as you can see form screenshot, that the TMSWebCore component is listed when a new TMSWebCore project is created and opened.

After reinstallation (latest version), I have got the same errors as before when adding events.

Also I'm still noticing that the component version reportaed as installed is 1.5.x


The version of the packages are ok, don't know why they are still showing 1.5.1. in TMS WEB Core

I could reproduce the issue with Lazarus 2.0.12 / fpc 3.2, but could not figure out the problem. Normaly I don't use this version, because TMS FNC Components are not compiling with this version. TMS WEB Core is running fine with Lazarus trunk / fpc 3.2

When creating a new project of type TMS WEB Core Application with an empty form, it compiles just fine. When I double click on the webform to create the OnFormCreate event handler, the error message shows up

When placing a control on the web form and try to compile the error message shows up

I just saw, that the reason for the compiler error is, that the Lazarus IDE is not adding the WebButton declaration to the source code. When I add it manually, it compiles. But there is still the issue that no event handler can be created.

Yes, exactly, that is what is happening. What could I do? There is any workaround? Or is it necessary to wait for any kind of fix? Thanks

I tested TMS WEB Core also with clean installed Lazarus 2.0.6 & 2.0.8 / fpc 3.0.4 - same behaviour. If you don't have the chance to install a current Lazarus trunk Version, I'm running out of options. End of this month TMS WEB Core VSC 1.3 should be available, which is basically identical to TMS WEB Core 1.7 but running inside Visual Studio Code. It offers all the different project types, like PWA and Electron which are not avialable with Lazarus. Personally, I really prefer the VSC version, it feels so much more comfortable to work with. You don't have to switch between the delphi/Lazarus and the JS world - you are designing and debugging directly live on the JS side - thats extremely cool stuff.

Hello! Thanks for you answer, really appreciated.

Where can I find the "current Lazarus trunk Version" ? What version have I to use precisely?

You are welcome. The (Lazarus) trunk version is a daily updated, permanently changing, version. There is no installer with it, you need to compile and install it by yourself. Its untested, might contain bugs, and TMS is NOT supporting these Versions. Most likely TMS will provide a fix, or knows a Lazarus version which is working.