Installation Verona 1.1 under Lazarus

I installed TMSWebCore on a WIndows 7 professional - 64 under Lazarus 1.8.4 - same result

Any suggestions or ideas from your side to make it run? 

Best regards

@ bruno

I found it thanks!

I installed a fresh version of Lazarus: 

I loaded the two packages you listed:

Then I did: 

2) Under the settings for TMS WEB Core, the path for the TMSWEBCompiler.exe needs to be set and the library paths.

** In the tabs in Linux I can now see the components .

I see this folder:
C:\Users\Cosmicbob\Documents\tmssoftware\TMS WEB Core RSXE11\TMSWebServer\bin

I did a search in MS Windows for this file " TMSWEBCompiler.exe"
It was not found anywhere.

There is a folder missing TMSWEBCompiler.

I tried to set the 4 (below)Lazarus Paths the same as the Windows setup for WebCore:

Web Compiler : $(TMSWebDir)\Compiler\libpas2js.dll
Installation directory: $(TMSWebDir)\Compiler\libpas2js.dll
Web Runner: $(TMSWebDir)\TMSWebRunner\bin\TMSWebRunner.exe
Web Server: $(TMSWebDir)\TMSWebServer\bin\TMSWebServerManager.exe

Is that issue somehow out of focus?

We are working through the backlog of some support tickets raised during xmas holidays and will also come to this.

Is it fixed in the todays TMSWebCore Setup?

The installer script was revised, it should be installed now.

Unfortunately there is still no TMSWebCompiler.exe installed

It should be,

it is under subfolder CommandLineComplier in the install folder

There is no subfolder \CommandLineComplier

I made a snapshot image from the installation directory, but I can't put it in this forum. If you like I can send it by mail


Are you 100% sure you effectively install v1.1.2.0

TMSWebCore.txt :

  // New : Headers/User/Password properties added to TWebClientConnection
  //       : New : Extended TApplication with RouteForm() and RunScript() methods
  //       : New : TWebEdit.Pattern, TWebEdit.Required, TWebEdit.AutoFocus properties added
  //       : New : TWebMessageDialog language customization support added
  //       : New : TWebForm.PopupOpacity property added for popup forms
  //       : Fixed : TabIndex handling in TWebPageControl, TWebSpeedButton
  //       : Fixed : Position issue with TJQXButton
  //       : Fixed : Issue with TWebSplitter design-time handling of height
  //       : Fixed : Keyboard navigation issue in TWebStringGrid

I assume you use the Lazarus-only distribution?
We've addressed this one too now and released v1.1.2.1

Yes, I'm only using Lazarus.

Just saw that new release. But I can't download it today, because I already downloaded the version from another computer this morning.

Is it possible to send me the version by email?

I did reset the download counter.

Thank you, the TMSWebCompiler.exe is installed now