Installation problem

I replaced my old notebook by a new one with Win7pro.

Delphi XE, XE2 and XE3 are installed. There is no previous TMS installation.

Installation of TMS component pack and Instrumentation workshop ran without problems.

Scripter Studio failed on all three delphi versions.

It seems this post does not allow attachments, so I can not add the install log and screenshot, I will mail them to you.


Gerhard Sachs

After TMS Component Pack install, and before TMS Scripter install, open and close Delphi so environment variables are updated and scripter can be properly compiled by the installer. I see errors only on XE2 and XE3 in your log, which just confirms my suspicions (XE install doesn't need this update).

I did a complete de- and reinstall, I deleted the complete TMS folder before reinstallation.

Then I installed TMS component pack, Instrumentation workshop and scripter in that sequence.

After each installation I started Delphi, tested the function with a new project and closed Delphi.

Before installing scripter, each delphi version was started and closed twice, all TMS components ran without problems..

However, i still have the same error messages when installing scripter.

Scripter was installed and seems to be usable on Delphi XE, it is missing on XE2 and XE3.


Gerhard Sachs

Is this v6.0.0.6?

The Subscription Manager tells me that the installed version  is the

Gerhard Sachs

The subscription manager first tells me that V6.0.0.6 is the latest version and offers to update to

If I agree and start, the new version is downloaded and starts with deinstalling the old versions.

This runs well with XE, but gives errors with XE2 and XE3.

After that, the manager displays latest version as and downloaded version as,

The only option I have is to install again, which leads to the known errors at XE2 and XE3.

Gerhard Sachs

The scripter installation problem persists.

On my notebook I have XE, XE2 and XE3 installed.

Scripter installs on XE, but fails on XE2 and XE3.

I did a complete reinstall, first removing ALL TMS components, reinstalled TMS component pack on all 3 Delphi versions, started all Delphis, tried the component pack, closed Delphi and then installed scripter.

The same problem as before, I get the same error messages.

Even using the default location did not change anything with the exception of a different directory name.

Gerhard Sachs

Can you try to uninstall all TMS components from vcl subscription, and then clean the "cache" of installed components, which would be:

1. Check which entries you have in  \HKCU\Software\tmssoftware. In theory you should have none (since you have uninstalled all tms comps). Tell us what do you have there, or if you feel confident about it, just delete it.
2. Check what you have in local settings\tmssoftware directory (C:\Users<username>\AppData\Local\tmssoftware in Win7 or C:\Documents and Settings<user>\Local Settings\Application Data\tmssoftware in XP). Check if you have folders like TMS Scripter Studio with some installers downloaded there. If you do, delete the installers.

Then let me know how it went.

This is what I did :

1. I deinstalled all TMS components with the exception of the subscription manager.

2. I deleted the HKCU\software\tmssoftware branch.

3. I deleted the c:\users\gs\appdata\local\tmssotware folder.

4. Reinstallation of TMS component pack, no problems during installation.

5. Started Delphing XE, XE2 and XE3, tested TMS installation and closed them.

6. Installed Scripter studio from subrciption mnager. Same error messages on XE2 and XE3, no problems on XE.

7. Tested XE2 and XE3, Schripter was installed, but disabled (checkmark in list of designtime packages not set).

8. Set checkmarks, Scripter seems to work, Checkmark keeps setting after restart of XE2 and XE3.

Currently Scripter works on all three Delphis.

I am still very suspicious, since in the list of designtime packages scripter is listed with its full path ( C:\compiler\addons\TMS... ). All other packages are listed just by their name ( e.g. TMS component pack ).

In XE, scripter is listed just by its name too, but not in XE2 and XE3.

At the moment I have a working solution.


Gerhard Sachs

I too am having problems. I have Xe3 and Xe4 installed and the installer says it cannot install these packages even though I've uninstalled and reinstalled in several cases.

Here is the first error:

Successfully compiled \psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\tmsscripter_xe4.dproj in Delphi XE4.

Successfully copied file \psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\tmsscriptervcl_xe4.dpk to \psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\Copy of tmsscriptervcl_xe4.dpk

Checking dependencies of tmsscriptervcl_xe4 in Delphi XE4.

Retrieving dependency path for dependency tmsd

Retrieving registry value in HKCU\Software\tmssoftware\TMS Component Pack

Dependency path retrieved: \psf\Home\Documents\tmssoftware\TMS Component Pack\DelphiXE4

Checking if file exists: \psf\Home\Documents\tmssoftware\TMS Component Pack\DelphiXE4\tmsdxe4.dcp

Dependency tmsdxe4.bpl found in \psf\Home\Documents\tmssoftware\TMS Component Pack\DelphiXE4.

Dependency GridPackxe4.bpl NOT found.

Dependency asgdxe4.bpl NOT found.

Adjusting package dependencies. 23, 2

Checking requirement. PackageIndex, iDep = 2, 1. Package: \psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\tmsscriptervcl_xe4.dpk

Adjusting package file. REQUIRES. Dependency found: tmsdxe4

Starting compiling of \psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\tmsscriptervcl_xe4.dproj in Delphi XE4.

Finding Root Path for Delphi Version 23

Delphi Root dir found: C:\Program Files (x86)\Embarcadero\RAD Studio\11.0

PACKAGE           : \psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\tmsscriptervcl_xe4.dproj

COMPILE PATH      : C:\Users\dave\AppData\Local\Temp\is-GEBRU.tmp\tmsbuild.bat

COMPILE PARAMETERS: "C:\Program Files (x86)\Embarcadero\RAD Studio\11.0\bin\rsvars.bat" "\psf\Home\Documents\tmssoftware\TMS Scripter\source\packages\xe4\tmsscriptervcl_xe4.dproj" "/target:Build" "/p:config=Debug" "/p:Platform=Win32"


After this error, there is the build output with info about why the build failed. Can you maybe send the full install.log file to our support e-mail.

Also, the log indicates you have TMS Pack installed. Please be sure that after you installed TMS Pack, and before installing scripter, you open and close Delphi, so that environment options are updated and scripter installer can succesfully compile scripter depending on tms pack.