Installation in RAD Studio 10.3


I recently installed RAD Studio 10.3 alongside an existing, working installation of 10.1.

I also downloaded and installed the new TMS Subscription Manager 2.

I tried to install TMSAsync. No errors were reported by TMS Subscription Manager 2.

However, while the installation in 10.1 was fine, the installation in 10.3 was incomplete.

When starting, 10.3 tries to load both VaCommPkgDEDXE12.bpl and VaCommPkgDXE12.bpl from C:\Users\Public\Documents\Embarcadero\Studio\20.0\BPL.

However those files are not there. A search of Drive C does not find those files anywhere. 

The search DID find VaCommPkgDEDXE10.bpl and VaCommPkgDXE10.bpl.

I tried to install a couple of other TMS products with the same results.

Any ideas what is going wrong?


Sometimes/seldom I also face problems with incomplete installations with Subscription-Manager.
In most cases the downloaded files in appdata/local/tmssoftware/TMS xxx were much smaller than should be. So I remove them from the appdata/tmssoftware/TMS xxx folder and re-download an re-install fine the affected product.

Not sure if it helps in your case, but you could give that a try...

Well I was able to manually compile and install TMSAsync but it to a bit of editing of the build configuration settings to get it all to work.

Thanks for the feedback.


I went ahead a tried installing a number of other TMS products and of the ones I tried only TMS WEB Core installed into RAD Studio 10.3


If there is an install failure, please send the installer generated log file under the Windows Documents folder to support by email. This will help to use analyze what went wrong on your machine and make a suggestion to solve it.