FNC Components are missing out of a sudden

I have worked with the FNC compoents for a while now, but today my project failed with "component XY not found". Although all FNC BPLs are installed and the chekcbox is selected, they are not listed in the palette. All other components (FMX, Aurelisu, ..) are here. I even tried to reinstall the FNC UI Pack, this succeeds, but the compoents still aren´t here.
Do you have any idea, what´s going on here?

Tx Bernd

I reinstalled all FNC components, but still get:

Have alook here:

The only thing, I changed was my monitor - I now have a 4k monitor.

This TMSFNCSVGImageCollection is the only component shown in the palette. :- (

Most likely you got an error during installation. Please check the log file in the Documents folder

Not sure, what I am supposed to look at. During installation there was no message. Have a look at the logs attached, please.

Moreover – I´ve had the components installed and working!

Tx for support,


TMS FNC Core_2.4.2.1.log (121 KB)

TMS FNC UI Pack_3.2.2.2.log (378 KB)


It seems the installation of RAD Studio is corrupt. It's unclear why this is the case, but the installation of TMS FNC Core & TMS FNC UI Pack failed because of the corrupt RAD Studio environment unfortunately. You'll have to re-install RAD Studio and make sure you are installing in a clean environment.

  C:\RAD\Bin\CodeGear.Delphi.Targets(402,5): error E2597: ld: warning: directory not found for option '-LC:\Users\bernd\Documents\Embarcadero\Studio\21.0\Imports' [C:\RAD_Lib\TMS\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj]
  C:\RAD\Bin\CodeGear.Delphi.Targets(402,5): error F2588: Linker-Fehlercode: 1 ($00000001) [C:\RAD_Lib\TMS\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj]
C:\RAD\Bin\CodeGear.Delphi.Targets(402,5): error F2588: Linker-Fehlercode: 1 ($00000001) [C:\RAD_Lib\TMS\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj]

But this is the build for OSX64 – this can´t be the problem.

Additionally, I can open the DPKs, compile and install them without any error message. The components just don´t get registered. I even can right click on the BPL in the "install components" dialog to show the contained components - and they all are there. But they do not show up in the palette and - see above - the classes can´t be found.

Hi, I noticed that TMS FNC Core installed for Win32 although there are errors in other platforms. It's unclear exactly why the components do not show up. Did you have the IDE running when installing? Did you uninstall the previous version before installing?

No, the DIE was not running on install.

Yes, I uninstalled before installing.

But please read the complete thread:

  • I had the components installed and working!
  • I changed my monitor (now 4K)
  • The components no longer showed up (only FNC!)
  • I tried to reinstall, this is the log you got.
  • I tried to install manually, got NO errer, but the comps do not show (only FNC)
  • I tried to change screen resolution, but this did not help

The IDE is running in a VMWare, if this is important.

Tx für your support!


VMWare tends to have issues. We hav e received similar reports in the past when working together with VMWare on various areas, not only related to our components. I strongly suggest to re-install the IDE and then start from there.

Sorry, but that is ridicolous. This is try and guess. Why should reinstalling the IDE help?

This is the first time we receive a report that changing the screen resolution to 4K destroyed the components in the IDE on a virtual machine. Additionally, the components were working in the IDE the first time you installed them, BEFORE changing the resolution, so either the IDE is corrupt, or the virtual machine is corrupt. We have had component installers running stable for several years so it is highly unlikely that there is an issue in our installers.

Also, we are trying to help, as this is a unique situation. The first thing that comes to mind is re-installing the IDE and see if that fixes the situation. If you are not able to re-install the IDE, alternatively, you need to try to re-install the components and see if that helps.

Pls read the thread. Reinstalling the components is what I alöready did. Your installers works ok, the components just fail to load. Why a reinstall of the IDE should help is open to explanation.

I appreciate your support, but reinstalling the IDE is not what I want to hear. :- /

Tx Bernd

I have another - and slightly older - instance of my VM with FNC Core and FNC UI installed, but otherwise identical. There the FNC components show up as expected.
I the installed FNC Core and FNC UI and voila the components do not show up.
So you are right - it is not the 4k monitor, but it seems to be related to the last update of your components.
Can I just reinstall the previous version? Or do I have to manually remove before installing the old version?

First, uninstall all FNC related components. Search on your system for all remaining DCU, BPL, DCP files related to FNC and remove them manually. Start the IDE and see if it starts normal. Then install TMS FNC Core, TMS FNC UI Pack and see if the components are shown. If they are not shown then it's unclear what exactly is going on. There is one thing you can do and check the registry for disabled packages.

Computer\HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\21.0\Disabled Packages

This is weird. I removed all TMS FNC files. I installed FNC Core and FNC UI Pack

Now the components are missing – although installed:

So the culprit is not the updated version.

Can you try resetting the tool palette?

I restored a snapshot with everything ok:

Changed scaling to 150% - still everything ok.

Installed patches fort he DIE – still everything ok.

Rebooted the VM – still everything ok

Update subscription manager only – everything ok

These versions are insatlled:

Downloaded updates and instslled them:

Komponents are gone:

Reset palette did not help.

BTW: This ist he startup screen where all FNC packages are listed:

Any idea?

If I reinstall the older versions, the components still are missing – except TTMSFNCSVGImageCollection.