DBAdvGrid issue latest release

I just updated my TMS Component pack

I believe I had before.

DBAdvGrid now shows

1. Most DBAdvGrids are WORKING.
2. What does not work :
 I have three DBADVgrids that the datasource is only defined at runtime.
i.e.,  set to NIL or a DS_myTable as needed,
with the LATEST Release these DBADVGRID show NO DATA!
-the underlying dataset is good and if I place a native DBGRID on the form they still work,
show data.
other information:  -- the DBADVGRIDS are in a FRAME which is in a FORM and the dataset
is the remote objects TDADatasource. 
This has worked correctly for a long time
Please advise.

We have not done any changes in the latest version that we think can have this effect. We cannot see a problem here with TDBAdvGrid used on frames. If a problem persists, can you please isolate this and provide some sample source project + detailed steps with which we can reproduce this here and investigate?

Problem has been solved:
- the column definitions (mapping to DB Fields) were lost.
-after recreating them all is ok again.
(was not using Autocreate)