AdvDBGrid not showing data in all rows

Was using VCL Component pack 7.200 - Just installed
Following items in one  TPanel
-Master data
with an edit and label component
- edit and label - aligned bottom
advDBGrid aligned client

There is another TPanel below with detail data
This panel is height re-sizable by a splitter
Upon first opening NOW the last rows show up on the main
advDBGrid but they appear EMPTY.
resizing the lower panel up or down 'makes' the missing data appear in the rows
that were already there...

THIS DID NOT OCCUR in earlier VCL component. -
Is there a new property to consider?
Or is this a 'bug'?

More info - this did not occur with the vcl component pack 7.200
Could it be a screen "paint" or refresh issue?
Screen shot showing issue in two places. :
below note 1: there are seven rows in the data set - only two are visible.
If I move the  splitter sightly the data on the 'invisible rows appear.
note 2: see the slight gap between the scroll bar and the last row - could this be it?
note 3: the detail grid shows 3 rows of data, but only the first two are 'visible'..
ONLY happens on first view of form and data. Subsequently data rows show as before
when db navigating.  TIA

image was not posted...

I have re-installed and the issue is gone.

I will wait for the next release and test again...

ISSUE STILL EXISTS in 7.3.00....

Some sort of elusive repaint issue?

-again - the # of rows in the grid is correct. Just the last 'few' rows appear
not to be populated...

As soon as I 'resize' the panel with the splitter bar all the rows showed data.

PLEASE look into

I'd suggest to send a sample source project with which this can be reproduced by email to support. That will be the most efficient way to investigate this.

Without knowing all property settings & code involved, it is very hard to guess what is going wrong.

May have found the issue...

need to change the DataSetType to dtSequenced - they WERE dtNonSequenced

All my advDbgrids were set to dtNonSequenced.
This was perhaps due to something from a long time ago..
Yet this did not matter 7.2 or earlier...
i.e., currently - grd in

Was there something changed about the property DataSetType?

Hope this is it! I will continue testing.

I downloaded & opened your project, grid.DataSetType was set to dtSequenced.
The project started working correct when I changed grid.DataSetType to dtNonSequenced.


I updated the component pack 
And with DGgrid  I have exactly the same problem described above.
Big problem for my because I can't update the software for my customer :!!
I tried to change DtNonsequenced for Dtsequenced and it seems to be better.
Is that the right solution ?
What is exactly the difference between DtNonsequenced and Dtsequenced  ?

dtNonSequenced is the setting for a dataset that can return buffers of records in a non sequenced way, i.e. a dataset that can not always return consecutive buffers of records. (records 1..10 followed by records 41..50 etc...)


Yes I understand, but as Poseika Rudy wrote :"Was there something changed about the property DataSetType?"
Before it was working well and now I need to change something.
I have 70 forms with your grid to modify, so  I want to be sure it is the right solution .


I did not have that many grids - maybe 10 or 12.
-it seems to have 'solved' the issue,
but I too would like to know 'what changed'?
It was easy enough to go through them.  My application has been around for
a long time and I had set the DataSetType to dtNonSequenced to solve some issue from
before before.... Then i copied one grid to other locations and that property moved with it.

regards all

There wasn't anything changed here recently that could affect this, so it is unclear why you start seeing this issue now.
Did something change recently at dataset level?

My environment for the application--
RemObjects DA
TMS VCL Component Pack <- Only change is here
latest updates for all.  - No changes have been made during this time when the issue emerged....

I have change the DataSetType and deployed the application - no other interesting side-effects reported...

Maybe you were using dtSequenced before while you would really have needed to use dtNonSequenced but no issues appeared. In simple scenarios, having DataSetType = dtSequenced for a non-sequenced dataset might not surface issues.


For me my sofware are as follow:
Delphi 2007
TMS VCL Component Pack
I have only change the TMS package .
I did some test , and I saw that the problem does not occur and never occur the fisrt time when I call the form.
But once the form is opened, when I navigate into the master data , the detail data displayed on your grid are not correct. (missing lines)

If a problem persists with the setting grid.DataSetType = dtNonSequenced, please contact us by email and provide some sample source app with which we can reproduce the problem here.

Just a small question:

How to know if my dataset is Sequenced or nonSequenced ?

I"m using the standart Tdatasource supplied with Delphi 2007

This datasource is linked to an IBquery.

My IBquery sql code contains always a line with 'ORDER BY.....'


"There wasn't anything changed here recently that could affect this, so it is unclear why you start seeing this issue now.
Did something change recently at dataset level"

Well, something has definitely changed. I installed the latest version, made absolutely no changes to my application, did a full build, and I saw exactly the same issue as others have noted - blank lines in the grid which fill after resizing the form.

Being on a deadline, and travelling for business tomorrow, I had no option but to restore my system to the last pre 7.3 build available to me, in this case, and rebuild. After wasting a bunch of time opening all of my forms to remove properties that were added in later versions of the TMS controls, I was able to do a full build and the problem vanished.

I don't have time to put together a test app as I'm traveling tomorrow, but there is definitely a problem in this latest build.

What is your setting for grid.DataSetType?