Can't post from within TDBAdvEdit


I'm trying to do the following:
Pressing <ctrl><s> should post the active record in a TUniQuery.

The code in KeyDown event of the form (Keypreview is activated, no keydown event for the components) is the following:

If I press ctrl-s in a TDBAdvEdit on the form, nothing is saved (post not fired) but the focus switches to AdvDBDatetimePicker_1.
If I press ctrl-s in AdvDBDatetimePicker_1 or a TAdvDBLookUpComboBox the post is fired and the changes are saved.

Putting the code into Keydown event in the component does not work either.

What is different in a TDBAdvEdit that causes this behavior?

I cannot reproduce this.
Test project

Hello Bruno,

thanks for checking!
I tried your project and it worked as expected.
Than I changed the ADOConncetion to a Unidac Connection with an AccessProvider with TUniQuery. I use AutoEdit all the time.
And it worked like in my post.
Well not quite. It seems I did not recognize, that the record indeed is saved but the dataset goes directly into edit mode after the post.
This only happens within TDBAdvEdit not TAdvDBDatetimePicker or TAdvDBLookUpComboBox.

Than I checked back with the ADO Connection and AutoEdit.
And it behaves like my test with UniQuery.

The problem seems to be AutoEdit but only within the TDBAdvEdit not in the other components.

I have an idea how to work around but if there would be a chance for you to adjust the behavior of all the components it would be great and time saving.

Thanks for these extra details.
This helped us to identify & fix the issue. We can confirm the next update will address this.

That sounds very good.
Thanks for dealing with my "special" problem and fixing it!