TWebDBcheckbox only updating DB-Field when WebDatasource. AutoEdit = true

I got a strange behavior:
Only less Controls (especially TWebDBCheckBox, TWebDBCombobox) needs to have TWebDatasource.AutoEdit = true to update the Database (MySQL)

If set to AutoEdit = false, the "click" shows the ValueChecked = true-behavior but after changing the record and go back, nothing has been updated ...

TWebDBEdit e.g. is working fine ...

Post and ApplyUpdate is done by even TXDataWebDataSet and / or TWebDataSource

System: TMSWebCore 1.6.2 ... other TMS all access license an all packages updated ...

Do I make a mistake ?
Goal is the implicit use of "Edit"-Button / "Post (Apply)"-Button for updating changes
(due to some central checks)
TeamViewer-Session is possible ...
Thank you for help !

Thanks for reporting.
We could see this issue and have applied a fix.
This fix will be in the release.

Hi Bruno,

many thanks,
Could you give me a time-schedule for this issue to be solved, may be a BETA-release ?
TWebDBCombobox does even not work properly (does not show / or is not updating "Text"-property on next record), I need this issue also solved for an WEB-App asap ;-)

We aim to release v1.7 next week.
I cannot see a problem with TWebDBComboBox.
Is the text value you try to set in the list of items?

Hi Bruno,
concerning release: sounds fine !

concerning TWebDBCombobox:
I try the following:

preset items at design-time: "Text1; Text 2; Text 3";

at run time:
select value "Text 1"
now the is set;
Text-Value disappears ... ( why ?)
After change to next record and then change back:
text.value = is empty
and the dbField at MySQL also NOT set

(reinistall of WebCore done ! and actual !)
TeamViewer is possible !


I especially setup a test project and I cannot reproduce this. (5.9 KB)

Hi Bruno,

thank you.
I made some more tests...
The issue happens while using WebDBCombobox with csStyle = dropdown.
I use dropdown-style due to having "standard-items from the list" but also having the availability to add a new text ...
The text-property will not be updated properly on skip to an other record.
The issue is when using XDATA ... with VCL-Server and WEBClient ... all components actual.
I enclosed all needed files (even MySQL -DB sql-file) (38.2 KB)

With this crucial information that it concerned a combobox with csDropDown style, we could trace & fix this issue.
The next release will address this.

fine, thank you !